Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When ever I long into Ubuntu, I'm immediately presented with a dialogue that asks me to enter the password that will unlock Gnome Keyring, however I was never prompted to set this in the first place, and none of the passwords I've tried are effective. How can I disable these popups and just have Gnome Keyring unlocked when I log in in the same way that encrypted home directories are automatically mounted upon log in. FWIW, I'm set to auto log in, which may or may not be useful information.

Btw, I've seen this question, and the accepted answer didn't work. I'd rather not uninstall Keyring

Update 1: I've disabled automatic login but it still appears.

share|improve this question
    

4 Answers 4

up vote 6 down vote accepted

It only comes up on auto login actually. To get rid of it :

  • Open seahorse (aka "Passwords and Encryption Keys" in the preferences menu),
  • Right click on "Passwords: login" (the first entry in the list),
  • Change password : "Old Password" is your user password, then do not type anything in "Password" and "Confirm",
  • then "Ok" and there will be a warning : "Use Unsafe Storage"
share|improve this answer
    
this doesn't work for me, I've changed to "Unsafe Storage" many time, and it keeps asking me for a password –  Felipe May 11 '11 at 14:34

Thats easy, OK first follow these steps:

  1. open your home folder
  2. press Ctrl +h to view hidden files
  3. double click on .local folder
  4. press on share folder
  5. look for key rings folder, right click it, and delete it.
  6. reboot
  7. you are going to see make a new key ring or default.
  8. press continue and press yes to the other pop up box.
  9. your done!
share|improve this answer

Mine is auto login too It asks me when I have to start my tweetdeck or connect to a network. Its fine with me now. but long time back when I changed my passwrod this gnome-keyring fails to authenticate. Thats why this time I havn't changed my pass word unable to find solution of this problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.