Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 64 bit Ubuntu 12.04 LTS and the computer won't boot. This is a Dell Precision Workstation 690 computer, which has a BIOS dated in 2006. It was running Red Hat EL 4 quite well. The Ubuntu installation proceeded without any problems. After installing Ubuntu 12.04, it has the following messages:

Controller Bus #00, Device#1F, Function#02: 00 Ports

No device found

AHCI BIOS not installed

I tried switching from AHCI to ATA in the BIOS, which eliminated these particular messages, but it still wouldn't boot.

What can I do to get this computer to boot with 12.04?

share|improve this question
add comment

1 Answer 1

I had the same problem. I got mine working by disconnecting all hard drives except the one for the OS (actually, my OS drive shows as a Dell Virtual drive as it is two drives mirrored by the Dell HBA) and re-installed with the Ubuntu server version thinking the server version may have better RAID controller support.

In the end, I think the problem was GRUB had not been installed properly (for whatever reason).

After installation, I reconnected my other hard drives and everything is working fine. To get my desktop back, I did a 'apt-get install ubuntu-desktop'.

I still get the same message re: no device found, AHCI BIOS not installed, but the message quickly goes by and the system continues to boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.