Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've never used Linux before and I can't even get it running heh. Basically I am using Ubuntu 12.10 in virtual box, at that least that's what I think I'm doing. Currently I am just watching this background picture though and I can move the pointer around but there's no menu bar or anything. I tried some hotkeys as well but nothing pops up and the only thing I've seen so far is Compiz crashing.

So my question is basically, how do I even get it running? I'd take a screenshot but there's nothing to show.

Specs:

  • Intel Core i5 2500K which should be like 3.3GHz I believe.

  • 8192MB memory.

  • NVIDIA GeForce GTX 560 Ti

  • Virtual Box specs:

  • Processor: 1 CPU at 100%

  • Memory: 512MB (The one listed under System > Motherboard)

  • Display > Video: 12MB memory

I hope I did that right now :)

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

Okay you most probably have a graphics card driver issue. There just may be a quick fix here. Try if you can rightclick on that desktop backround. If you get a menu then choose:

Change Desktop backround.

Thats just a backdoor to get into the system settings without having to revert to a terminal. If that works, You will be in the appearance tab of the systems settings. Click the all settings tab and go to

Software Sources

Here, go to the last tab (Additional drivers)and you may see a list of drivers for your graphics card. Choose the X.Org xserver, if its displayed.

This might bring your system back to being able to display Unity, and get you started

If that doesnt work then hit CNTRL-ALT-t to get a terminal and enter

sudo lshw -C display

Post the output back here.

gd luck


Issue was finally identified as:

https://forums.virtualbox.org/viewtopic.php?f=3&t=51727

uninstalling unity 3d and installing KDE desktop resolved this. (see comments below)

share|improve this answer
    
Yeah I can't rightclick the background so I'll have to go with the other method. However it would seem like Ubuntu is lagging a lot, the terminal took forever to open and it looks like I can't write into it currently. Maybe I should get an older version and try to upgrade? Currently waiting for the terminal to respond, I think it might have worked earlier when the pointer looked like [] instead of a white square. –  Latedi Jan 25 '13 at 23:58
    
mm okay. You may have given your virtualbox instance just too little juice. Or you just may have low specs on your system itself. Can you post the system specs for your system and for the virtual box system. Especially CPU, Memory and graphics card –  matv1 Jan 26 '13 at 0:04
    
Okay, I added the information to the question above as it was easier to format. –  Latedi Jan 26 '13 at 0:13
    
I think your Virtual Box is too limited. Your base system is certainly more then sufficient. Looking at the VB specs: I –  matv1 Jan 26 '13 at 0:21
1  
Thanks a lot! All I needed was to get rid of Unity 3D and install that KDE desktop instead. To get into the terminal without the lagg i created a new virtual machine and reinstalled Ubuntu. Then when receiving the question about if I wanted to update it was possible to open the terminal, probably before the dekstop had booted or something. Not the simplest way to go about it but hey it worked :) Is there anything I should do like posting it as an answer or give you a +1 or something? –  Latedi Jan 26 '13 at 2:35
show 8 more comments

I had this same problem earlier, but I was able to fix it by:

  1. Use both a boot disk AND a bootable flash drive. To make a bootable flash drive, follow these instructions. Put both the disk and the USB in your commuter, then restart. If the disk s ejected, push it back in. When you hear the startup chime, immediately press and hold C until it boots from the disk

  2. You may still see the background and nothing else. That's ok. What ended up working for me was to just wait a really long time. I saw the blank wallpaper, went to dinner with my family, and when I came back I saw a desktop with icons and everything.

share|improve this answer
    
Sorry I'm using virtualbox, not a "real" computer :p Although the problem was pretty much the same. If I may ask, did Unity 3D start performing better after you just waited or what did you do afterwards? –  Latedi Jan 26 '13 at 2:37
    
Unity 3D... Are you referring to the game engine? I was unaware that had anything to do with the question. Also, I was only having the problem you had with running ubuntu off the live CD. It works fine now that its installed on my hard drive. –  Chuck Dries Jan 26 '13 at 3:40
    
Actually I have no idea if it's the game engine or something happening to use the same name. But the desktop that came with 12.10 is called that... I think. –  Latedi Jan 26 '13 at 3:51
    
OOOOOOooohhh yeah I forgot, they just call it "unity". Sorry I'm a game dev, so the game engine popped into my mind at first. So inside your vm, I believe virtual box allows you to boot from an ISO, yes? So you're booting from an ISO, and trying to install ubuntu inside of virtual box. Is that the case? I was having the same problem, but I was using my 21" iMac, but I still think the results should be the same. Just let it sit there and eventually stuff will start to load. –  Chuck Dries Jan 26 '13 at 3:59
    
I'm an aspiring dev myself actually, working a lot with the engine. But I got it working with matv1's help so don't worry. –  Latedi Jan 26 '13 at 11:41
show 1 more comment

There are several programs that will brick unity if used improperly. If you were doing any heavy hacking, you may have "broke" it. (I'm not a super linux techy, but a somewhat experienced computer user, so i'm speaking more from my trial and error process of trying to craft the "perfect" desktop for me) If you are super Unity attached, you might have to just reinstall ubuntu.

First see if you can log in with one of the other desktop enviroments (Gnome 3, Gnome classic are installed by default, just click on the Ubuntu logo on the login screen)

If that doesn't work

See if you can open the terminal with Ctrl-Alt-T,

Then try "sude apt-get install ubuntu-desktop"

If that doesn't work, install another desktop enviroment.

share|improve this answer
add comment

I just set up Ubuntu for the first time on my Windows 7 Asus laptop using VirtualBox, and I had the same problem of only getting the background screen. So I searched in google to find this.

However: in the meantime the problem fixed itself. It seems that I just had to wait a bit longer and then Ubuntu automatically continued the installation process.

So, just saying it may be a good idea to just wait a little and see what happens. I had the background screen showing only for about 10 - 15 minutes before the rest of the installation processes continued.

Of course, there might be another issue, but no harm in waiting as a first option :-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.