Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As you can see from the title, I am having trouble with booting into the newest kernel of Linux (3.2.0-36) from the grub. I am dual-booting Windows 7 Pro with Ubuntu 12.04 and running Ubuntu as my primary OS. I have done a lot of checking in the forums and still haven't found a solution that solves my problem.

My problem is that when I attempt to boot into the default Linux kernel, the boot takes forever and nothing is displayed (except a purplish screen that reminds my of the BSOD). I am a total noob to Ubuntu so I have no idea what I can and can't do in the boot, such as opening terminals, getting error reports, etc. I started using the 12.04 just a few weeks ago. If I do a boot repair (which I had to originally from the LiveCD in order to get the grub to work), I can boot into the newest kernel quickly once and then every subsequent boot takes forever. Also, I have noticed that there are a few stability issues, such as programs randomly closing (my screencasting software). However, one last thing to mention, I am able to boot into a previous version of the kernel (I am currently in 3.2.0-26).

Does anybody have any ideas?

P.S. If you want to see any error reports, you will need to "spell it out" due to my status as a noob, but I do want to learn all that stuff so feel free to slap me upside the head. :)

share|improve this question
    
I have boot repaired up and down the ying-yang. Nothing works. I even tried reinstalling the grub. Didn't work. –  DaBungalow Jan 25 '13 at 23:38
    
If the updated kernel often fails to boot and causes stability problems when it does run, that's probably a bug; I recommend reporting it as such. (This question also has some good information about bug reporting.) After reading that (or at least the first linked page), you can start the report by running ubuntu-bug linux. This will probably be closed as off-topic, in accordance with the FAQ and this policy. –  Eliah Kagan Jan 26 '13 at 2:46
    
Since you have tried everything here, you should make sure to include a detailed explanation of what you tried and what happened, in the bug report. In particular, it's important that the report make clear that boot options like nomodeset did not fix the problem. –  Eliah Kagan Jan 26 '13 at 2:48
add comment

marked as duplicate by Eric Carvalho, Jorge Castro, qbi, Eliah Kagan, Thomas W. Jan 26 '13 at 3:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

That's a kernel regression.

  1. Short-term solution: remove the 3.2.0-36 kernel from your /boot/grub/grub.cfg file. (use gksudo gedit /boot/grub/grub.cfg to edit it), or remove the packages related to 3.2.0-36.
  2. Also report the bug to kernel developers, via the ubuntu-bug linux command. If you don't, you will have the same bug in future Ubuntu releases.
share|improve this answer
    
Okay. Thanks for the info. I was wondering what was causing that. However, I still have a few problems with the current kernel (unable to shutdown. I forgot to mention that in the original post). Is there anything, I can do to fix that? Maybe, I will try to re-install??? –  DaBungalow Jan 26 '13 at 0:52
    
You can try the sudo shutdown now command. Reinstalling won't change anything. –  LovinBuntu Jan 27 '13 at 22:55
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.