Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can anybody tell me the way to change MAC of wlan0?

I have tried macchanger commands but nothing works (Ubuntu 12.10-Broadcom Network Adapter).

This is what I am getting:

enter image description here

I have tried the following:

shivendra@shivendra-Rev-1-0:~$ sudo ifconfig eth1 down
[sudo] password for shivendra: 
shivendra@shivendra-Rev-1-0:~$ sudo service network-manager stop
network-manager stop/waiting
shivendra@shivendra-Rev-1-0:~$ sudo macchanger -a eth1
Current MAC: 00:21:00:72:9c:d5 (unknown)
ERROR: Can't change MAC: interface up or not permission: Too many open files in system
shivendra@shivendra-Rev-1-0:~$ sudo macchanger --mac 64:27:37:D8:97:6F eth1
Current MAC: 00:d0:61:9d:bf:a5 (Tremon Enterprises Co., Ltd.)
ERROR: Can't change MAC: interface up or not permission: Too many open files in system
shivendra@shivendra-Rev-1-0:~$ sudo service network-manager start
network-manager start/running, process 2182
shivendra@shivendra-Rev-1-0:~$ sudo macchanger --mac 64:27:37:D8:97:6F eth1
Current MAC: 64:27:37:d8:97:6f (unknown)
ERROR: Can't change MAC: interface up or not permission: Too many open files in system
share|improve this question
add comment

5 Answers

Sorry if I'm wrong, isn't there a GUI option in Network manager. Click on the network manager icon > select Edit Connections > Edit your ethernet's properties and look out for Clone MAC address field and enter your new MAC.

share|improve this answer
add comment

If you click the networking icon in the Unity 'taskbar' on the top right, then go to Edit Connections, you should be able to switch to the Wireless tab and open an Edit dialog for your connection.

In this edit dialog, the first page has a field to edit your MAC address. You can type right into the text field.

share|improve this answer
add comment

Are you sure that modifying eth1 is what you want to do?? Check your Wifi interface name with ifconfig.
What I would do:

sudo service network-manager stop  
sudo macchanger -a wlan0
sudo service network-manager start
share|improve this answer
    
Every other solution i tried was not working for me, but using this i can access the wifi's of others who are protected by mac address. Thanks a ton –  deadman Mar 31 at 10:01
add comment

You are editing eth1 instead of wlan0, change eth1 to wlan0 and your MAC-address command will work.

So everywhere there is eth1 like this:

sudo macchanger -a eth1

should be like this:

sudo machchanger -a wlan0
share|improve this answer
add comment

I wrote a little script that uses macchanger -A to get another MAC address and then updates the necesserary wlan files. Check it out.

Cheers,

Manuel

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.