Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 installed on /dev/sda partitions and Windows 7 on /dev/sdb partitions. In the past I have been able to boot into Windows 7 from /dev/sdb2 or /dev/sdb3. Now I can't anymore. I have done several Update Manager updates since the last time I tried to boot Windows. Today when I tired I got:

Error: no such partition Press any key to continue.

I'm running kernel version 3.2.0-36-generic. I suspect that this was installed since the last time I tried to run Windows 7. Can you help me?

I have seen several suggestions that I should run update-grub, but I want to be sure I should before trying.

share|improve this question
    
SOLVED PROBLEM: I concluded that my Windows 7 /dev/sdb drive had failed and replaced it with a new one that I installed Windows 7 on (took several hours - with downloaded updates!). To verify that the old drive was dead I ran: 1) os-prober: returned nothing, 2) fdisk -l /dev/sdb, returned nothing, 3) cat /proc/diskstats, showed only my /dev/sda partitions. Then I ran update-grub and it removed the Windows 7 option from the boot list. So the old disk was not visible. After building the new disk I reran os-prober (showed Windows 7) and update-grub. The Windows 7 option was then present. Thanks!! –  SaberCat Jan 27 '13 at 16:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.