Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have VirtualBox 4.1.10 running in an Ubuntu 10.04 64-bit host. It ran perfectly until today.

When I launch it, the main window opens and, above it, the new version available notification window. Normal behavior until this point. But when I click the OK button to close the new version window, the main window also closes. No error message is displayed.

I've tried running sudo /etc/init.d/vboxdrv setup and also reinstalling VBox but I still have the same issue.

I've tried again today (Without doing any change). Now, the new version available windows does not appear. Also the main window does not dissapear, but when I try to start the virtual machine (Windows XP) I get this message:

A session for Güindous virtual machine cannot be opened.

Failed to load VMMR0.r0 (VERR_SUPLIB_OWNER_NOT_ROOT).

Resultat Codi:NS_ERROR_FAILURE (0x80004005)
Component:Console
Interfície:IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}

Anyone has any clue about what's wrong?

share|improve this question
    
Try running VirtualBox in a terminal to read potential errors. Post these here if you don't understand them. –  Takkat Jan 25 '13 at 19:16
add comment

1 Answer

I've found this:

http://ubuntuforums.org/showthread.php?t=1857854

So, in a terminal, check by entering:

ls -ld /usr /usr/lib

If it doesn't show "root root", then enter:

sudo chown root:root /usr /usr/lib

Now it's working again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.