Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Ubuntu 12.10 laptop recognizes and displays on many models of external monitors and projectors without issue, but with the Optoma HD20 the projector shows "No Signal" and the display is otherwise blank. I suspect Linux/X.org display issues. How can I confirm this and submit information that will enable support?

Hardware Details:

The laptop is a Dell XPS Ultrabook (L421X) running 12.10. This laptop has Intel 4000 and NVIDIA 630M graphics, and lsmod shows nouveau and i915 drivers loaded. This model has both HDMI and mini DisplayPort. I've tested HDMI more extensively, but whenever I've tested with a miniDP-HDMI adapter, the results have been the same as direct HDMI.

The projector is the Optoma HD20. This projector has HDMI inputs and native 1920x1600 projection. We have two of them, and all behaviors described here are identical for both of them.

What I've tried:

When I plug the projector into my laptop, the projector is recognized quickly as OTM 72" in Settings > Displays, but the projector declares "No Signal" and has blank display. (Is OTM 72" right?) Xorg.0.log shows sensible frame buffer allocations based on laptop and various selected projector resolutions. Clicking "Apply" leads to the 30s timeout dialog in which the laptop display is fine (i.e., not garbled) and the projector says "no signal".

Both projectors work fine with Macs.

I have tried multiple cable and cable lengths.

I have tried multiple resolutions, with and without mirroring.

http://harts.net/reece/tmp/optoma-hd20.edid-decode contains the edid info generated by edid-decode /sys/devices/pci0000\:00/0000\:00\:02.0/drm/card0/card0-HDMI-A-1/edid .

share|improve this question
    
are you booting the laptop before or after plugging in the projector? Often it will work better if the projector is plugged in before boot. –  ImaginaryRobots Jan 25 '13 at 18:01
    
I've tried connecting before booting, but no difference. –  Reece Jan 28 '13 at 21:13
    
12.04.1 has same behavior. –  Reece Feb 1 '13 at 20:09
    
I posted a bug to launchpad bugs.launchpad.net/ubuntu/+source/xorg/+bug/1112859 –  Reece Feb 2 '13 at 18:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.