Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Freeplane mind-mapping software. It creates .mm files which Nautilus reports as Troff MM input document. I want to be able to open a file with Freeplane by double-clicking it in Nautilus.

I have a .desktop file for Freeplane with the mime-type set as application/x-freemind.

I added a mime-type for *.mm files as application/x-freemind but this didn't change anything.

Right-click Open with… still doesn't show Freeplane.

Freeplane is installed in a folder under home simply by unzipping an archive and adding a .desktop file under ~/.local/share/applications pointing to the freeplane.sh script file.

How do I associate .mm files to Freeplane.

I'm using Ubuntu Quantal Quetzal.

share|improve this question

2 Answers 2

A quick way would be to open the terminal and go to a folder where a mm file is. Then do the following:

mimeopen -d FILE.mm

A small terminal based menu will appear asking you, to which program you wish to associate the mm extension. If none in the list are freeplane, then simply select option 5. Then type the executable for freeplane, which I will assume it is freeplane. This will make freeplane open the file used. Now close and open any Nautilus window (You may need to actually logout and login again) you have opened and you are done. Next time you right click a mm file, freeplane will appear in Open With.

UPDATE: Ok installed freeplane and did the step mentioned above (I was right to guess the executable was freeplane) and this is what I came out with:

enter image description here

It appears in the image above as the first option becase I had already done it althought I did not check if it was there in the first place.

enter image description here

Just to make sure, do a sudo apt-get install --reinstall freeplane. Just tested in 12.10 and 13.04. If it still does not work, can you provide any additional information that can help me narrow down the cause?

share|improve this answer
    
Give me a couple of minutes to install freeplane. –  Luis Jan 30 '13 at 16:41
1  
Thank you for your help. I found that the problem was with the .desktop file. Instead of %f at the end of the exec line there was a %U. Change done, Freeplane appeared amongst the possible applications. –  To Do Jan 30 '13 at 17:01
    
@ToDo - No problem buddy. Glad I helped somehow. –  Luis Jan 30 '13 at 17:13

Adapted from https://answers.launchpad.net/ubuntu/+source/nautilus/+question/180627:

  1. Install Freeplane with the Ubuntu Software Center, or type sudo apt-get install freeplane in a shell.
  2. Install the program File Types Editor (also known as AssoGiate) from the Ubuntu Software Center, or type sudo apt-get install assogiate in a shell.
  3. Open this Editor (type assogiate in a shell) and click on the "New" button to add a new type. Enter in the following information:
    • General tab:
      • category: Multipurpose files
      • name: freeplane
      • description: mindmapping
      • default icon: (browse to select your Freeplane icon -- look in /usr/share/icons/hicolor/scalable/apps/)
    • Related Types tab:
      • add an alias to application/x-freeplane
    • Filenames tab:
      • add the *.mm pattern
  4. Click OK to complete the addition of the new type, and close assogiate.

Now you should be able to open .mm files from Nautilus using Freeplane.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.