Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed QTCreator and Ubuntu SDK as shown here. When trying to run the code sample provided here, QTCreator tells me it can't find the Ubuntu.Components QML Module.

Notes:

The build-logs says:

file:///home/giladnaaman/Programming/Projects/CurrencyConverter/CurrencyConverter.qml:2 module "Ubuntu.Components" is not installed

But the directory /opt/qt5/imports/Ubuntu/Components exists (and is full of files).

After adding importPaths: [ "/opt/qt5/imports" ] to the qmlproject file:

QML module does not contain information about components contained in plugins.

QMetaType::registerType: Binary compatibility break -- Type flags for 'QPaintBufferCacheEntry'[1024] don't match. Previously registered TypeFlags(0x103), now registering TypeFlags(0x3).

share|improve this question
add comment

1 Answer

It can not work, if you install Ubuntu UI toolkit according that website. http://developer.ubuntu.com/get-started/gomobile/#step-get-toolkit

I reinstall Qt5 and Ubuntu UI toolkit according this website, and problem have gone.

You must compile Ubuntu-components and then install it into Qt5. This article tell how to do it. Can't install qt-components-ubuntu because I'm using full release of QT 5.0.0

It will work for Qt Quick1/2 UI project not for Qt Quick1/2 Applications projects.

Hope it works for you!

share|improve this answer
    
How do I compile Ubuntu-Component? Where can I download its source? –  Gilad Naaman Jan 27 '13 at 11:17
    
Hi Gilad, i posted wrong website.link.This is right website. It will tell you how to download Ubuntu-components and compile it. –  thuai Jan 27 '13 at 11:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.