Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install vlc media player on my ubuntu 12.04 using terminal by following command:

    sudo add-apt-repository ppa:videolan/stable-daily
    sudo apt-get update
    sudo apt-get install vlc

and got an reply of

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

    The following packages have unmet dependencies: vlc : 
Depends: vlc-nox (= 2.0.5+git20130123+r508-0~r42~precise1) but it is not going to be installed 
Depends: libavcodec53 (>= 4:0.8-1~) but it is not installable or libavcodec-extra-53 (>= 4:0.8-1~) but it is not installable 
Depends: libavutil51 (>= 4:0.8-1~) but it is not installable or libavutil-extra-51 (>= 4:0.8-1~) but it is not installable 
Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable 
Depends: libtar0 but it is not installable 
Depends: libva-x11-1 (> 1.0.15~) but it is not installable 
Depends: libva1 (> 1.0.15~) but it is not installable 
Depends: libxcb-composite0 but it is not installable 
Depends: libxcb-keysyms1 (>= 0.3.8) but it is not installable 
Depends: libxcb-randr0 (>= 1.1) but it is not installable 
Depends: libxcb-xv0 (>= 1.2) but it is not installable 
Recommends: vlc-plugin-notify (= 2.0.5+git20130123+r508-0~r42~precise1) but it is not going to be installed 
Recommends: vlc-plugin-pulse (= 2.0.5+git20130123+r508-0~r42~precise1) but it is not going to be installed

then i tried it using software centre then here comes its reply The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 2.0.5+git20130123+r508-0~r42~precise1) but 2.0.5+git20130123+r508-0~r42~precise1 is to be installed
     Depends: libavcodec-extra-53 (>= 4:0.8-1~) but it is not going to be installed
     Depends: libavutil-extra-51 (>= 4:0.8-1~) but it is not going to be installed
     Depends: libc6 (>= 2.15) but 2.15-0ubuntu10 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
     Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.2 is to be installed
     Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.2 is to be installed
     Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
     Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
     Depends: libtar0 but it is not going to be installed
     Depends: libva-x11-1 (> 1.0.15~) but it is not going to be installed
     Depends: libva1 (> 1.0.15~) but it is not going to be installed
     Depends: libxcb-composite0 but it is not going to be installed
     Depends: libxcb-keysyms1 (>= 0.3.8) but it is not going to be installed
     Depends: libxcb-randr0 (>= 1.1) but it is not going to be installed
     Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
     Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed

now what to do pls help me

share|improve this question
add comment

2 Answers 2

First a question: Is there a reason you are trying to install VLC from it's daily PPA?

Why not simply remove or disable that PPA, use the Ubuntu Software Center and search for vlc then install? You will get the latest supported build.

If you must use the daily ppa, then you need to dig into the 2 unmet dependencies to understand where to get them from since they are not readily available to you for whatever reason.

share|improve this answer
    
When I try installing vlc via software center it shows network connection error so i tried installing it via ppa –  Goku Jan 26 '13 at 6:59
add comment

PPA are private repos.

In this case it may require software available in Ubuntu 12.10

So either do not use that PPA (and maybe download generic binaries) or upgrade to Ubuntu 12.10.

share|improve this answer
    
When I try installing vlc via software center it shows network connection error so i tried installing it via ppa, and now i've able to install it now i changed my update server to usa and were able to install it –  Goku Jan 26 '13 at 7:00
    
If that is solution, than post your own answer. Someone can stumble on same problem in future! –  przemo_li Jan 26 '13 at 9:48
    
Thanks for the help I've solved my prob by cleaning it –  Goku Feb 1 '13 at 16:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.