Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a rather strange problem with Dropbox that started a few weeks ago.

Dropbox will stop syncing with the message "Can't access Dropbox folder", and refuse to sync until I reboot.

I've tried restarting Dropbox and logging out, but nothing I seem to do will allow it to sync again short of a reboot.

This is not a permissions problem, as the permissions don't change when I suddenly lose access.

I've checked lsof for anything related to dropbox that might still be hanging on when I stop it. As far as I can tell nothing else other than Dropbox is accessing it's folders when this happens.

share|improve this question
I believe there was a recent kernel update that fixed it for good. – CraigM Feb 8 '13 at 18:33
up vote 26 down vote accepted

if you put these in /etc/sysctl.conf:

fs.inotify.max_user_watches = 1048576
fs.inotify.max_user_instances = 256

it will fix.


sudo sysctl fs.inotify.max_user_instances=256
sudo sysctl fs.inotify.max_user_watches=1048576

the problem is that it has run out of inotify instances. you can try e.g. tail -f /var/log/syslog, and if you see

tail: inotify cannot be used, reverting to polling: Too many open file

then you know this is your issue. For me it was nepomuk.

share|improve this answer
Interesting. I'm seeing dovecot complaining: lister dovecot: imap(craig): Warning: Inotify instance limit for user 1000 (UID craig) exceeded, disabling. Increase /proc/sys/fs/inotify/max_user_instances. Will add and see if that makes the problem disappear. Thank you! – CraigM Jan 27 '13 at 1:11
Going to accept this answer for now, as it makes the most sense. Will check back if I run into it again. Thank you! – CraigM Jan 27 '13 at 1:23
I had the exact same problem on a brand new installation of Ubuntu 12.10 with default settings. Increasing max_user_instances as described here solved the problem. – Holger Jan 27 '13 at 20:29
For Ubuntu, sudo echo 256 > /proc/sys/fs/inotify/max_user_instances gives a permission denied error. sudo sysctl fs.inotify.max_user_instances=256 should be used instead. – törzsmókus Jan 27 '13 at 21:41
I can confirm that this fixes the problem for me (Ubuntu 12.04) – Raja Selvaraj Jan 28 '13 at 1:00

The fs.inotify.max_user_instances=256 fixed my immediate "Can't access dropbox folder" problem (Ubuntu 12.04).

It also cleared up an odd behavior I'd noticed, where the dropbox systray icon continually indicated file activity: The arrow circles cycling continually, though nothing was changing in my dropbox, and the "recently changed files" list remained unchanged.

A few moments after I changed fs.inotify.max_user_instances=256, the pointless cycling stopped.

share|improve this answer

In one of the forums, someone mentioned it is due to inotify. They have this solution/workaround.

  • disable desktop search (in kde nepomuk+tracker, in gnome tracker)
  • reboot (logout didn't help)
share|improve this answer
I'm not running tracker as far as I know. Is there a particular process I should be looking for? – CraigM Jan 26 '13 at 16:01
sudo sysctl fs.inotify.max_user_watches=1048576
sudo sysctl fs.inotify.max_user_instances=256
share|improve this answer
Welcome to ask ubuntu could you elaborate on your answer a little more please so folk know what you are doing here – damien Sep 22 '13 at 0:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.