Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've spent almost an entire day trying to make flash work. I first tried doing installing adobe-flashplugin. Firefox detects the plugin in about:plugins, but does not show the version number [ it is left blank ].

I tried removing adobe-flashplugin and installing ubuntu-restricted-extras. But the same result.

This is my output for dpkg -l \*flash\*

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                            Version              Architecture         Description
+++-===============================-====================-====================-  ====================================================================
un  flashplayer-mozilla             <none>                                    (no description available)
un  flashplugin                     <none>                                    (no description available)
un  flashplugin-downloader          <none>                                    (no description available)
ii  flashplugin-installer  amd64                Adobe Flash Player plugin installer
un  flashplugin-nonfree             <none>                                    (no description available)
un  libflashsupport                 <none>                                    (no description available)

Any ideas?

share|improve this question
What do you have in ~/.mozilla/plugins? Do you see there? – user25656 Jan 25 '13 at 12:28
Not initially. But then I uninstalled everything I had and got the tarball from adobe's site and then manually added it in ~/.mozilla/plugins/. Still no luck – user125991 Jan 25 '13 at 12:51
Just clarifying, firefox is detecting the plugin [ it shows up in about:plugins ]. But when I try adobe's flash test It shows a plugin is needed to display this content under Adobe shockwave player – user125991 Jan 25 '13 at 13:01
the issue is that you have to install Shockwave Player, which doesn't exist for linux. There is workaround described here --> – titusjaka Mar 9 '13 at 12:17
@user125991 You would have to go to the test plage for Flash and not for Shockwave: – Michael Tanner Mar 15 '13 at 13:53

The Shockwave player is only available for Windows.

The solution is to install Shockwave in firefox in wine, and then call that one from Your linux firefox with mozplugger.

Here's a guide. It have several steps. Works for me.

share|improve this answer

Here's one way to debug this.

What you have installed, is not necessarily what you're actually running. It is typical to have old versions of flash installed in various places under ~/.mozilla/plugins for example.

In order to figure out what's actually loaded into your browser, I suggest the following 3 step method:

  • Figure out the process id of the process which loads the flash plugin this will depend on the browser, e.g. in firefox, you need to look for a process called plugin-container
  • Run lsof -p <pid> | grep libflashplayer (replace <pid> by your step 1 discovered process id), to see the full path from which is actually loaded.
  • Finally, once you have the full pathname of the libflashplayer DSO you can figure out its version by running strings on it and extracting what looks like a version number (4 numbers separated by dots)

Here's a little proof-of-concept shell script implementing which-flash on a running firefox.

# which flashplayer are we using?
# look for firefox-bin and/or plugin-container

for arg in "$@"; do
    case "$arg" in
        moz*)   pat="/[m]ozilla" ;;
        -x)     set -x ;;

# filter out parent procs ( and grab the pids
pids=`ps xawww | egrep "$pat" | grep -v | sed 's,^ *,,' | cut -d' ' -f 1`

for pid in $pids; do
    echo ======= pid: $pid =======
    output=`lsof -p $pid | grep libflashplayer`
    case "$output" in
        '')  echo "You need to load flash in the browser first" 1>&2;
            exit 1 ;;
    echo "$output"
    # extract the dso from the matching line:
    dso=`echo $output| awk '{print $NF}'`
    echo "flashplayer is in: $dso"
    # Also print version of libflashplayer:
    # Unfortunately there are many numbers in this dso, so we have
    # to restrict the major version number...
    echo version: `strings $dso | grep -P '^(1[1-9])\.\d+\.\d+\.\d+\$'`

Chrome is similar except in the 1st step you need to look for the process that has a runtime argument like: --plugin-path=/usr/lib/flashplugin-installer/ in the ps output. YMMV.

The reason to go through all this process is to ensure you're actually running what you think you are (the official installed version from /usr/lib/flashplugin-installer/ If you're not, you can remove the old versions and try to restart the browser to see if it loads the correct version. For the record, I'm running Ubuntu 64-bit too and have no issues with libflashplayer loading and running. The version as of 2013-03-17 is

share|improve this answer

Flash installing is not hard for FireFoxes, but you have to reconcile with yourself to deal with kind of devil regarding the fact that even OpenSource-Gnash developers are not allowed to use adobe flash by law..

1]Get the tar.gz from official Adobe(R) Flash(R) site by pressing the "Download" button from

2] Extract that tar.gz's, the other files can be ignored and deleted

3] Open a file manager like nautilus or whatever and paste the into (If there is no directory called "plugins" in your hidden .mozilla folder then just create it with *right-klick-New and name it "plugins") in your home-directory

CLI alternative (not as root):

mkdir ~/.mozilla/plugins
mv /path/where/you/extracted/ ~/.mozilla/plugins

4] (Close and) Open Firefox and check in address bar if Shockwave Player is there


(If you followed instructions it is there! Just disable other flash stuff in "Extras → Add-ons" to be sure the proprietary one is used)

Have fun with it as long as HTML5 won't chase it out of earth;)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.