Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got Skype working with iBus (and it took a while at the time), but recently both my working set-up (on 12.04) broke, and any attempts for a new set-up (on 12.10) failed. (On 2 separate computers.)

That is to say, iBus does not input in the Skype window any longer. (iBus is running, and selecting the Anthy input method has no effect when the cursor is in the Skype window. It works fine via keyboard shortcut or the iBus menu in other applications.) I have the lines

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
export XIM_PROGRAM=/usr/bin/ibus-daemon

in my .bashrc. And have the qt & gtk versions of ibus installed. Has anything changed for Skype and iBus to stop working?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I just found the solution for this!

/usr/bin/ibus-daemon must be started with -x option.

I've added 'iBus' to startup applications with following command:

/usr/bin/ibus-daemon -x -d

I also have following lines in my /etc/environment but I'm not sure if they affect the result somehow (don't really want to experiment now):

LANG="en_US.UTF-8" 
LC_ALL="en_US.UTF-8"
GTK_IM_MODULE=ibus
XMODIFIERS=@im=ibus
QT_IM_MODULE=ibus

Update: variables mentioned above has no any effect really in case of skype

Update 2: on Fresh installation of Ubuntu 12.10 I just installed ibus-qt4 (not ibus!) and selected iBus as IME. It works without any additional tricks

share|improve this answer
add comment

What worked for me with mnemosyne (a Qt-application) and IBus was: Just change the Qt input method to XIM (I know you're using IBus, so do I.).

I don't know why this works but it was the only thing that worked for me. Adding system variables like QT_IM_MODULE=ibus etc in ~/.bashrc and ~/.xprofile only crashed my IBus instance so it didn't even work in Gtk-Apps.

You can change your this setting by running qtconfig-qt4 (you have to install it first).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.