Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created a new partition on my hard drive because my /tmp partition was too small. I changed the mountpoint in /etc/fstab and rebooted.

Every time I reboot, I get the following error message at the login screen:

There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)

When I log in, /tmp is mounted correctly and everything seems to work fine. When I reboot, the error shows again. When I change the /tmp mountpoint back to the old partition, the error message disappears.

What could be causing this and how can I solve this issue?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

This appears to be a sticky bit problem. /tmp needs to have permissions of 1777 (drwxrwxrwt ), please note the last 't' flag.

Compare permissions of /tmp using ls -ld /tmp with new and old partition and if it is different,

Try changing permissions on new partition.

sudo chmod 1777 /tmp 
share|improve this answer
    
This has solved my problem. Thanks! –  Aron Rotteveel Feb 6 '11 at 16:44
    
Great to know :) –  Jamess Feb 6 '11 at 16:57

I guess you deal with a corrupt file system.

Boot from a Ubuntu install disk(flashdrive) and run fsck with the -fy option on your hard drive (/), this will fix several things and cur the error message.

Please let me know, if this fixes your problem!

Regards, Ilias el Matani

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.