Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried setting different acpi_os, acpi_backlight=vendor, changed the kernel to 3.7.4, and yet nothing happens when I use the FN + F5/F6 keys to change the brightness. KDE recognizes it and will change it in the software but the LCD backlight does not respond. I have also tried the custom asus wmi drivers which didn't work as well. Anything else I can try? I'm running Kubuntu 12.10 with AMD Catalyst 13.1 drivers. Thank you!

share|improve this question

I've been facing this problem on my K52 (I was using Gentoo that time). I had tinkered with kernel till I got it working.

I can't remember which of these config parameters was the key (here is listing from opensuse 12.2). Unfortunately, I don't have any gentoo config any more, to have a look at it:

$ uname -r

$ zgrep ASUS /proc/config.gz

I'd try to rebuild the kernel with those flags set to "y".

You might also try some live distro, where those keys are working and copy kernel config from it.

As for other features (suspend etc.), this thread is a great help:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.