Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the No Machine windows NX client to connect to an Ubuntu 12.04 server. In Ubuntu I have the keyboard set to English (UK) in System Settings > Keyboard Layout. In Windows 7 I have the location set to United Kingdom and keyboard English (United Kingdom). However when I log on to the Ubuntu server it seems I have a US keyboard layout.

Edit: I understand that NX defaults to a US keyboard layout if it doesn't understand the keyboard of either the client or the server. I've spent several hours looking for resolutions on Google, i.e. setxkbmap gb on the server. However doing that generates the message Error loading new keyboard description.

Edit2: When I tried using the onBoard on screen keyboard to get around the issues, most of the keys came up with question marks. The space bar contained the message "No X keyboard found, retrying...". Could this have something to do with why my keyboard isn't mapping correctly? The Ubuntu system is derived from the Rackspace Ubuntu 12.04 image with a GUI subsequently installed (I believe it's Unity).

share|improve this question
1  
Have you changed the mapping in the NX client? –  Uri Herrera Jan 24 '13 at 22:56
    
@UriHerrera Looking around Google yesterday, quite a few people suggested doing that but I don't seem to have that option. They mention that you can change the keyboard mapping on the advanced tab of the client. On my advanced tab I have network and system settings but nothing that seems to relate to a keyboard setting. My client version is NX Client for Windows Version 3.5.0.9. I've also looked in the keyboards config file for NX client as per other instructions, changing the UK entry from gb to en_GB but that had no effect. I've changed that back now. –  Giles Roberts Jan 25 '13 at 13:48
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.