Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Unity on 12.10, with most of the Compiz Effects disabled. I'd like to remove the fade effect when using the CTRL+ALT+D default shortcut to show the desktop. The effect consists in fading out the active windows and fading 'em in when they get focus again. I couldn't find anything in CCSM or dconf to set the value of the fade effect to zero.

share|improve this question

3 Answers 3

Similar functionality of hiding all windows and showing the desktop is right now provided by several plugins: Show Desktop, Fade to Desktop and Ubuntu Unity Plugin, that seem to conflict with each other. Among those you'd of course choose Unity Plugin if you are using Unity, but it has no configurable option to control the fadeout.

More about the current status of the problem an proposed fixes here - https://bugs.launchpad.net/compiz/+bug/1063171 and here - https://bugs.launchpad.net/unity/+bug/1067534.

The simplest workaround I have found so far that allows to achieve the requested effect is to go to Ubuntu Unity Plugin -> Switcher and disable Show minimized windows in switcher in CompizConfig Settings Manager. Obviously not a very elegant solution, but those like starting showdesktop after unityshell with gconf, proposed in bug 1067534 have been explicitly forbidden in bug 1063171 and will remain such until Unity 7 or compiz 0.9.9.0.

share|improve this answer
1  
thanks for tip. Many milliseconds in my life has been recovered. –  pylover Feb 16 '13 at 1:31
    
Glad it helped someone, but personally I had to switch that box back on since switching windows became very unusual (well, I told you this is not a very nice solution, but I don’t know if there is another one as of the time of writing). –  Pavel A Feb 16 '13 at 13:09
    
there was no problem for me. everything is good. –  pylover Feb 16 '13 at 17:00

The slow fading was bothering me for a long time until about 5 min ago, when I changed the settings in CCSM Fading windows plugin from "constant speed" to "constant time", and minimized the corresponding value (to 1, I think).

Now, "show desktop" (ctrl alt d) is way faster and near instant.

Note that I was reluctant to just disable the fading-windows plugin, because I think the dim unresponsive windows setting serves a good purpose as quite a useful visual indicator of system (un)responsiveness.

share|improve this answer

I am unsure how to disable that specific effect but if you want to disable all compiz effects (by going into ow graphics mode) you should do the following:

gedit ~/.xprofile

Then enter the text export UNITY_LOW_GFX_MODE=1

Logout then log back in

To check if this worked enter in the command glxgears -info

The output should look something like

GL_RENDERER = Gallium 0.4 on llvmpipe (LLVM 3.1, 128 bits)

GL_VERSION = 2.1 Mesa 9.1-devel

GL_VENDOR = VMware, Inc.

I hope this helps. Not quite the answer you are looking for but this should do it

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.