Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 12.10 (32-bit) a few weeks ago (from 12.04) and everything has been running fine. A few days ago, the updater installed the latest kernel (3.5.0.22 ?) and since then I always have to manually select the latest kernel when booting.

I tried looking for /etc/default/grub but that file didn't exist. I installed Grub Customiser but that, apart from taking minutes to appear, suggested that the default kernel was '0'. But it did create a small /etc/default/grub file with the following entries:

    GRUB_DEFAULT="0"
    GRUB_TIMEOUT=10
    GRUB_SAVEDEFAULT="false"
    #UNNAMED_OPTION=""

I have run sudo update-grub and have also tried changing the default from "0" to 0 but grub insists on defaulting to the previous kernel.


uname -a in the manually-selected latest kernel gives:

Linux typhoon 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8 21:41:11 UTC 2013 i686 i686 i686 GNU/Linux

Letting the boot timeout and select the default kernel results in:

Linux typhoon 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:52:46 UTC 2012 i686 i686 i686 GNU/Linux

The boot menu looks like this: boot menu

My machine has 2 hard disks. The main disk is dual-boot with 12.10 (default) and winXP.
The 2nd disk is purely for data and isn't mounted automatically i.e. selecting it in nautilus always mounts it before displaying anything. It is available to both operating systems and is formatted as NTFS.


fdisk -l results in: fdisk response

sda1 is the WinXP partition.

share|improve this question
    
When you boot to the "previous" kernel, what does "uname -a" say after booting? Also, on the grub boot menu, what do you see? Can you post a photo? Do you have multiple hard disks in the machine? Can you be sure it's not installing the boot loader onto the disk you're not booting off? –  popey Jan 24 '13 at 13:59
    
+1, you may have a thumb drive or something plugged in. –  Richard Jan 24 '13 at 14:28
    
Definitely, nothing extra plugged in. –  Neil Balderston Jan 24 '13 at 14:45
    
Can you let us know the output of "sudo fdisk -l" to list all partitions? Chances are your PC is booting off one disk, but "grub-install" is installing grub on the other. That boot menu looks wrong. I'm pretty sure in 12.10 and above we now just list "Ubuntu" and not the kernel version until you drill down or choose to boot an older version? This further makes me think you're booting from the wrong (older) grub on the 'other' disk. –  popey Jan 24 '13 at 14:58

1 Answer 1

OK, the newest kernel (v23) was installed today and everything has now suddenly reverted to normal i.e. the latest kernel is found by default.

So, not quite sure what caused the previous blip - never experienced that before and my PC config hasn't changed for several years - but it seems to have resolved itself before I got around to trying to find grub on my data disk and moving it.

One quick question though... Popey mentioned that he thought the 12.10 grub list just showed "Ubuntu" rather than the kernel version. Mine definitely still shows version numbers the same as always. Is that a problem?

share|improve this answer
    
If you upgraded from an older version of Ubuntu, you may have an older grub. This shouldn't be a problem. Please ask a separate question rather than ask a new question in the answer to the old question. –  user68186 Feb 1 '13 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.