Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have pretty decent laptop and should be more than enough for running Ubuntu for browsing and watching movies, but Ubuntu seems to be getting much hotter than it should, compared to Win 7. I'm on Ubuntu 12.10.

I have Asus N53SV. CPU: Intel® Core i7-2630QM RAM: 6GB DDR3 GPU: NVIDIA GeForce GT 540M

Here's picture of XSensor when I have only Firefox open, it should be around 40C so that's 20C more than usual.

XSensor

share|improve this question
    
Welcome to Ask Ubuntu! Is this an Nvidia Optimus enabled machine? Are you running Bumblebee or not? –  gertvdijk Jan 24 '13 at 14:46
    
Thanks! Yes, it does have Nvidia Optimus enabled and no I'm not running Bumblebee. Should I try it? –  Vasar Jan 24 '13 at 16:24
    
Depends on what you want to accomplish, but in the current state it is probably running two GPUs as it has no knowledge about the hybrid functionality (as far as I understand). Personally, I would just disable the Nvidia card completely in the system BIOS (if possible), as I'm not running games and the Intel HD Graphics is quite capable of doing video acceleration and simple desktop effects. –  gertvdijk Jan 24 '13 at 16:27
    
I use Photoshop and might play games sometimes on Win7 so I don't really want to disable my Nvidia GPU altogether. –  Vasar Jan 24 '13 at 16:31
1  
I think these temperatures are not excessive high. How high is the CPU load? Are the measurements at 40 degrees on the same machine? –  Seth Jan 24 '13 at 17:47
add comment

2 Answers

up vote 3 down vote accepted

Since you have an Optimus-enabled laptop, you'll want to install Bumblebee.

Without Bumblebee, you are most likely using the integrated graphics chipset, while your dedicated graphics card is powered on, which will generate more heat and consume more power.

Moreover, the problem is generally worse when using the open source nVidia driver.

In a nutshell, Bumblebee disables that GPU and allows you to work in a low-power state. It also allows you to use your GPU whenever you need more graphics power.

Windows does this too, automatically, which is why you don't run into the same problem under Windows.

--

Before installing Bumblebee, remove any graphics drivers you might have installed.

After that, installation of Bumblebee and the proprietary nVidia driver can be done with the following commands:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

After that, reboot, and your laptop will use the low-power integrated graphics chipset and leave your dedicated GPU powered off.

You can always start an application that requires your full GPU power by running it "with bumblebee":

optirun your-application

--

Should you run into trouble after the installation, the following page might help you: https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting

share|improve this answer
    
I did that, it seems to have helped a bit, don't really know yet. I'll report back tomorrow. Thank you very much for all the replies! –  Vasar Jan 24 '13 at 21:41
    
Temperature is still the same after installing Bumblebee. I know the temperature isn't that high, but I know for a fact that it can run a lot cooler. So does anyone have any ideas what else could it be? Thank you! :) –  Vasar Jan 25 '13 at 17:23
    
Maybe you have one or more processes that keep consuming CPU power? You probably already did something similar, but if not, run the top command and see if nothing is running in the background that could generate that heat. From my personal experiences, the CPU and GPU are the primary causes of laptop overheating issues... –  Mr. Pixel Jan 25 '13 at 17:35
1  
Well I disabled the Firefox crash plugin, what ever it's called it seemed to be eating a lot of CPU. I switched over to Chrome altogether, now it's running on 50C. Though the temperature still is bit higher than on Windows. I used Windows for a day and it was running at around 40C, but the temperature went up after switching back to Linux around and bit over 50-55C. I guess I'll just have to accept it. –  Vasar Jan 28 '13 at 6:54
add comment

My laptop had the same problem after a reinstall. In my case it turned out that somehow the cpufrequtils package wasn't installed and my processor were running amok.


Update:

Also cleaning the fan from dust reduced its temp by another 10 degrees or so.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.