Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Dropbox installed on my Ubuntu desktop 12.10, I also have Firefox and Chrome installed. Chrome is my default browser, I have checked in my mimeapps.list and its all correct. Yet for some reason the integration of Dropbox opens Firefox when I use the "Launch Dropbox website" option from the menu, is there a file somewhere this is looking at as I would like it to open in Chrome which I mostly have already running than launching a new instance of Firefox? Or could this be a Dropbox bug?

share|improve this question
    
On my computer it opens in Chrome (set as default browser). What's your dropbox version? I have 1.6.16 under Ubuntu 12.10. –  panmari Jan 24 '13 at 12:41
    
I am running 1.6.16 too. –  kbot Jan 24 '13 at 13:15
add comment

3 Answers 3

up vote 1 down vote accepted

I had similar problem with my Xubuntu 13.04 and I solve it with this commands.

$ sudo update-alternatives --config x-www-browser

  Selection    Path                Priority   Status
------------------------------------------------------------
  0            /usr/bin/opera              200       auto mode
* 1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/firefox            40        manual mode
  3            /usr/bin/opera              200       manual mode

Press enter to keep the current choice[*], or type selection number:

x-www-browser was set right because I want to use chromium-browser but problem was with next command where for gnome-www-browser was set opera.

$ sudo update-alternatives --config gnome-www-browser

    Selection    Path                Priority   Status
------------------------------------------------------------
* 0            /usr/bin/opera              200       auto mode
  1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/firefox            40        manual mode
  3            /usr/bin/opera              200       manual mode

Press enter to keep the current choice[*], or type selection number:

So you just need to select the browser you want to use, in my case its chromium-browser, so I entered number 1 and it solve my problem with Lunch Dropbox Website in different browser.

share|improve this answer
    
It was indeed the 'gnome-www-browser' that was the problem, although for me it was set to use chrome, it was set to auto mode. So I changed it to open chrome in manual mode and this fixed the problem, thank you! –  kbot Mar 21 '13 at 13:45
    
I use Lubuntu 12.04 and I changed both entries to chromium-browser manual mode, but still Dropbox (and its Nautilus integration) starts Firefox. I have Chromium set as preferred web browser in Lubuntu preferences. –  jarno Oct 25 '13 at 12:06
add comment

Dropbox is still a gtk2 application while Unity and current Gnome are on gtk3. Gtk2 applications store their settings in gconf instead of dconf. Maybe they got out of sync.

Edit the following key:

/desktop/gnome/applications/browser/exec

with the gconf-editor user interface (available as package) or with gconf command:

gconftool -s /desktop/gnome/applications/browser/exec -t string google-chrome

Last not least there are the debian alternatives system, use package galternatives and change key x-www-browser to your liking.

Note that google-chrome is not the same as chromium-browser.

It is also possible that dropbox keeps the browser that it encountered during install, in this case please report the bug.

share|improve this answer
    
I followed your instructions but both keys are showing that google-chrome is the browser, so I am thinking this is a Dropbox bug after all. Thanks for the help. –  kbot Jan 25 '13 at 12:07
add comment

For me, none of ways to change default browser worked. It was probably Dropbox bug that was fixed in newer version.

Use solution from Dropbox ignoring my default programs

If it does not work, you can try combining it with any of other answers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.