Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I moved from KDE to Xfce, and I've found that I cannot use Super+Space as a keyboard shortcut (applied via the Xfce keyboard settings program).

My main concern is that I use that shortcut to open up my drop-down terminal (which is currently xfce4-terminal using the --drop-down option). The catch so far has been that I can use Yakuake with this keyboard shortcut, but not xfce4-terminal.

share|improve this question
    
@maggotbrain Considering that it's in the man page, yes. –  aperson Jan 28 '13 at 3:00
add comment

1 Answer

The xfce4 drop-down functionality was recently added in Xfce4-terminal version 0.6.1. whose release was announced just about two weeks ago.

According to launchpad, there appear to only be source packages(not .deb files) for the Raring release.

Adding the PPA:

There are PPAs available from the xfce-dev team for 12.04 and 12.10.

To add these repositories, run the following commands from the terminal Ctrl-Alt-t:

sudo add-apt-repository ppa:xubuntu-dev/xfce-4.12
sudo apt-get update
sudo apt-get install xfce4-terminal

Configuring the keyboard shortcut:

In order to set up the Super-Space functionality, follow these steps:

  • Go to Applications Menu --> Settings --> Keyboard.
  • Select the Application Shortcuts Tab and Select the Add button.
  • For the shortcut command field, enter xfce4-terminal --drop-down and select OK.
  • Finally, enter the keyboard combination that you wish to use for your shortcut.

For more information on this functionality, see the webupd8 article or this one article. The webupd8 article has instructions on configuring the drop-down functionality that you are looking for, I believe.

share|improve this answer
    
This is entirely not an answer to my question. Not to be rude, but I already have xfce4-terminal with dropdown mode installed. My question is the super+space issue. –  aperson Mar 15 '13 at 1:04
    
@aperson I've added steps on how to add that shortcut to my answer. If you are already have that keyboard shortcut set up specifically to use with Yakuake, then the short answer is you cannot use the same keyboard combo for another application. –  Kevin Bowen Mar 15 '13 at 1:28
    
That still does not help. I have long uninstalled yakuake and xfce will not let me use super space as a keyboard shortcut for anything. My only reasoning for bringing up yakuake was that it can use super+space whilst any app in xfce cannot (even if all kde apps are uninstalled). –  aperson Mar 15 '13 at 5:28
    
@aperson Are you getting any sort of error messages? I am running multiple DEs on several boxes and that shortcut is working just fine switching between Kubuntu, Xubuntu, gnome, and Unity without any issues. Unless you can provide some specifics in regards to your system or any error messages there is not much more I can help you with. –  Kevin Bowen Mar 15 '13 at 11:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.