Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to create a windows accessible partition(FAT16/FAT32). But even the created partition can read under linux. It can not see on Windows. Just display a driver symbol like E:.

I'm using parted to create the partition. And then use mkdosfs -a -F32 -v /dev/sdc2

Disk /dev/sdc: 2022MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      4096B   22.0MB  22.0MB  primary  ext3
 2      22.0MB  56.6MB  34.6MB  primary  fat32        lba
share|improve this question
    
According the maintainer of dosfstools. Daniel Baumann <daniel at debian.org> told me. That's Windows' feature. –  Daniel YC Lin Jan 25 '13 at 6:53

1 Answer 1

According to this linuxquestions thread, Windows needs the FAT32 ID type to be 0xc instead of the mkdosfs default of 0xe.

In my anecdotal experience, GParted will automatically make FAT filesystems that Windows can read, so if that is an option, it may be something to consider.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.