Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 4 Gig USB drive that I'd like to format.

I go to the Disk Utility, and try to format it, but it says that the device is busy. (This same error occurs no matter whether I tried to format the whole drive, or just the partition.)

So, I do some research, and figured out how to disable automount. It's now disabled.

To be on the safe side, I first unplug then reconnect the USB stick then tried:

sudo umount /dev/sdb
sudo umount /dev/sdb1
sudo umount /dev/sdb*

Now, the Disk Utility STILL gives me the same error - usually "/dev/sdb is busy" or "/dev/sdb1 is mounted" or similar.

share|improve this question
3  
Why don't you use GParted which will allow you to unmount from the context menu and do whatever you want to do (chech, format, label, etc.) easily? –  Sadi Jan 24 '13 at 12:30
1  
Oh, man, I forgot about GParted. I had that a while back, I loved it. After I had to reinstall Ubuntu, I sort of forgot about it... Thanks for reminding me about that! I actually figured out the problem, though: I'd left the Startup Disk Creator open, and for some reason, it was auto-mounting my flash drive... –  JamesTheAwesomeDude Jan 24 '13 at 14:37
    
add comment

1 Answer

Run df -h in terminal and make sure there is nothing mounted that looks like /dev/sdb*. I had /dev/sdb11/ and /dev/sdb8 mounted so I had to run umount /dev/sdb11 and umount /dev/sdb8.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.