Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install the Quanta Plus, a web development IDE. When I try to configure the file using ./configure then this will display:

subhajit@Reaper:~/Downloads/kdewebdev-3.5.8$ ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for kde-config... not found
configure: error: The important program kde-config was not found!
Please check whether you installed KDE correctly.

I find some stuff like

sudo apt-get install kdelibs5-dev

and

sudo apt-get build-dep kstars

but this is not working.

If there is another way to install the Quanta Plus? Then please tell me how to install.

I'm using Ubuntu 12.04 32bit.

share|improve this question
1  
Welcome to Ask Ubuntu! What is the reason for to not use the Ubuntu package and compile a very old 3.5 version from source? Package name: kdewebdev - just do sudo apt-get install kdewebdev. I believe the Quanta Plus is a very old name for one of the apps in the now KDE web development suite. –  gertvdijk Jan 23 '13 at 23:36
    
Thank You Very Much. Can You Please Tell Me How To Start This kdewebdev –  Reaper Jan 23 '13 at 23:46
    
Maybe my answer isn't really clear, but it's not fit for KDE4, so not fit for Ubuntu. You'll not be able to run it. Look for alternatives. –  gertvdijk Jan 24 '13 at 0:08
    

2 Answers 2

I'm using 12.04 LTS and was succesfull using this way to install QUANTA+:

[Update] Since Natty is not longer supported, I tried successful to use the Lucid-repositories ;) I think it's possible to install Quanta on this way up to the end-of-lifetime of lucid.... [/Update]

First you have to add the packages of LUCID to your sources list.

Open an editor of your choose with the soucres.list, I do it in this case with gedit.

# sudo gedit /etc/apt/sources.list

and insert the following lines to end of the file

deb http://archive.ubuntu.com/ubuntu lucid main universe restricted multiverse

deb-src http://archive.ubuntu.com/ubuntu lucid universe main multiverse restricted

deb http://security.ubuntu.com/ubuntu/ lucid-security universe main multiverse restricted

deb-src http://security.ubuntu.com/ubuntu/ lucid-security universe main multiverse restricted

deb http://archive.ubuntu.com/ubuntu lucid-updates universe main multiverse restricted

deb-src http://archive.ubuntu.com/ubuntu lucid-updates universe main multiverse restricted

deb http://archive.canonical.com/ubuntu lucid partner

deb-src http://archive.canonical.com/ubuntu lucid partner

Now save the file and exit gedit

Update your package-sources:

# sudo apt-get update

Install QUANTA

# sudo apt-get install quanta

Install missing apps (e.g. kommander), the KDE4-versions are working with QUANTA, only cervesia can't be used.

Have fun ;)

share|improve this answer

Forget about Quanta Plus, start looking for alternatives

The last release of Quanta Plus was about 5 years ago: version 3.5.9 (see all versions). They are working on a port to KDE 4. This port seems also a bit dead, as I see only a few commits over the last year and no tags besides the 4.2 - tag version that might work with kdev 4.2 which does not sound very much stable.

Because the whole stable source still needs Qt3 and KDE3, you won't be able to compile it anyway without huge efforts.

The kdewebdev package now contains some other useful tools, though:

  • kfilereplace
  • kimagemapeditor
  • klinkstatus
  • kommander

For alternatives to Quanta Plus see: Basic Web Development IDE/Editor like Dreamweaver?

share|improve this answer
    
Thank you a lot! I found everything without kommander. Can you tell me how to open kommander? –  Reaper Jan 24 '13 at 0:07
    
@Reaper kommander --help It's not something you really want to run as a desktop application. –  gertvdijk Jan 24 '13 at 0:09
    
Can you please tell me a good web development tool for Ubuntu without kompozer, Bluefish, netbeans. Like Dreamweaver. –  Reaper Jan 24 '13 at 0:23
    
@Reaper Look for the many questions already out there on this site! Tip: use the search with the tags software-recommendation, web-development and ide. –  gertvdijk Jan 24 '13 at 0:24
    
Thanks a lot..... –  Reaper Jan 24 '13 at 0:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.