Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an interesting problem that I can't seem to fix. I am running into the problem outlined here and there is a solution posted by user ecadman. However, the steps to fix it are:

  1. Alt+F2
  2. gconf-editor
  3. /->app->metacity->global_keybindings
  4. Change the assigned keystroke for show_desktop from Super+D to Ctrl+D or Ctrl+Alt+D or disabled.

and I do not have a global_keybindings folder under metacity. I also am missing a gnome_settings folder under apps, which was another workaround.

Other notable problems, all keyboard related, are: I cannot access the keyboard layout settings, and the on-screen keyboard has all question marks over the letters and says X keyboard cannot be found, retrying on the spacebar.

Other than the D key not causing input and instead triggering the shortcut, the rest of the keyboard works fine. I even went into the keyboard settings in both gnome and Ibus and disabled the hide all windows shortcut (in gnome settings) and tried to disable the D key from triggering shortcuts (in Ibus settings).

I'm not really sure where to go from here. It's a standard en-us keyboard. I also do not have local access to this machine, but do have full ssh access and can add whatever else I need if necessary.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Found a solution. While I was simply disabling the key bindings for hide all windows, I simply needed to rebind it to some arbitrary combination and the problem stopped. Hope that helps anyone with the same issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.