Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently upgraded to Ubuntu 12.10 and since then conky has been acting up. This is what it looks after a while (specially if I use the option 'Show desktop' by draggin the mouse to a corner, as Ubuntu Tweak permits you to do):

enter image description here

This is my .conkyrc file and my ~/.conky/bargraph_small.lua file.

I tried tweaking the setting around but it seems a bit random, at times it will work and at times it will not. Any ideas? Cheers.

share|improve this question
add comment

2 Answers 2

up vote 19 down vote accepted

I had the same problem with conky in fluxbox. I solved the problem by changing

own_window_type override to own_window_type normal (line 17 in your .conkyrc)

Check out more conky configuration settings here:

http://conky.sourceforge.net/config_settings.html

The above answer would apply in most cases, however in this particular case it doesn't work well. The Ubuntu Tweak "Show desktop" option minimizes all open windows. Your .conkyrc line 16 states own_window yes. This means that conky has it's own window. By stating own_window_type normal the window is being told to act "normally" (can't move it around though). Thus the conky-window will as well as any other window minimize when the "Show desktop" option is used. The line own_window no is not an option because this causes placement problems.

The solution would seem to be to make the window stick to the desktop which would be achieved by changing the line own_window_type normal to own_window_type desktop. However, although this causes the conky window to stay on the desktop when "Show desktop" is used, when the desktop is being clicked left or right for some reason the conky window dissappears again.

What so far seems to keep conky in its place is changing own_window_type normal to own_window_type dock. The drawback of this method is having to place conky on the right spot on your desktop again using gap x and gap y. Gap x is now counted from the left side of the desktop edge instead of the right side. Gap y is still counted from above. So suppose your screen resolution is 1440x900 and gap x used to be 10 and conky maximum with is 250, the new gap x would be 1440-250-10=1180

In addition, to entirely lose any visible dock borders change the line own_window_transparent yes with the lines: own_window_argb_visual yes and own_window_argb_value 0. So in your .conkyrc line 18 will have to be replaced by two lines, 18 and 19 with the new code. When own_window_argb_value is set to 255 the conky window will have no transparency and be black.

This solution has been tested and appears to work. The solution is based on the config_settings in the link above.

share|improve this answer
    
This has the drawback that when I use the 'Show Desktop' function by dragging the mouse to a corner (feature provided by Ubuntu Tweak) conky disappears (I guess it minimizes) never to be seen again... –  Gabriel Jan 24 '13 at 16:27
    
'Show desktop' by draggin the mouse to a corner, how do I activate this feature with the latest version of Ubuntu Tweak? So far I haven't been able to duplicate the behavior of your conky. I used your rc and lua on a freshly installed Ubuntu 12.10. –  jeroen Jan 25 '13 at 15:14
    
Open Ubuntu Tweak, Settings > Workspaces and select 'Show desktop' action for one of the corners (mine is top right). –  Gabriel Jan 25 '13 at 16:27
    
See my improved answer! –  jeroen Jan 26 '13 at 1:58
1  
Well, I think we're there. Cheers –  jeroen Jan 28 '13 at 15:25
show 5 more comments

I have an another ansver for you.

1)Just let the window be own_window_type normal

2)and go to compiz config manager.

3)then go to window borders

4)Click the + icon next to window types, that shall have borders to add an exception.

4.1) Then while conky window is open; set the type to "window name" and next to value click "Grab". then grab the conky window.

4.2) Then check the checkbox "reverse" or "inverse" or whatever it is.

5) Do the same for shadows.

6) Happy conking

The problem is, that it doesent appear on all workspaces. (IF one of you knows a solve, let me know). Next problem: if you click on conky window, it jumps on all other windows just like a normal window would do. Also "show desktop" is a problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.