Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was given an Ipod touch 2g by a friend. Used it for awhile on its own, but wanted to link it to my computer. Tried Gtkpod & Rythymbox for mounting/syncing Ipod with Ubuntu, but there always comes a pt. where something fails or simply doesn't exist as the instructions say, and then I'm lost, as I am essentially computer illiterate (a friend set up Ubuntu for me, but he doesn't know mp3s) So I 'wiped' it by clicking 'reset all settings'. Now it's useless. Touch screen shows a usb cord aiming at ITunes logo. So, what to do? Currently, when my computer asks if I want to Initialize Ipod, and I click OK, I get this error message:

DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered

My computer is using Lucid Lynx

ps - unclear on distinction among sync, mount & initialize...

share|improve this question
1  
Ipods need to connect to iTunes at least once to get registered with an iTunes account. You'll need to do it on a Windows or Mac OS X machine (or virtual machine) before anything running in Ubuntu will work as far as I know. –  Garry Cairns Jan 23 '13 at 22:55
add comment

2 Answers

Unfortunately, you need a Windows or Mac OS environment to initialize your iPod. once you have that, i believe you can use it via iTunes in Ubuntu, but you have to init it via Windows or Mac first.

share|improve this answer
    
OK - hadn't seen TLoT's answer before I edited. Will attempt to initialize via Windows. But then I HAVE to use iTunes in Ubuntu? Any further clarification appreciated. –  clifman Jan 25 '13 at 16:45
    
That's not what I said. I merely said you need a Windows or Mac environment to init the device. I didn't say you have to, i said you can. not that you have to. –  Thomas W. Jan 26 '13 at 3:24
    
Sorry if I wasn't clear. Can I then use it with something else - like Rhythmbox or gtkpod in Ubuntu, without using iTunes after the initialization in Windows or Mac? –  clifman Jan 26 '13 at 5:09
    
I tend not to use my iPhone music sync with anything other than iTunes, mainly because its the iPhone and i don't want to risk it dying, so I can't answer that question. –  Thomas W. Jan 26 '13 at 20:47
    
All I want is to be able to save/play mp3s (podcasts, mostly) from my laptop to/on the Ipod. Doesn't seem a lot to ask. But remains out of reach. Any help appreciated. –  clifman Mar 3 '13 at 21:24
show 6 more comments

You can use ideviceactive from the libimobiledevice suite to activate your device from Ubuntu.

Since you are using 10.04, download it from here: https://github.com/posixninja/ideviceactivate/ (Direct Link)

And follow the instructions:

Open a terminal (Ctrl+Alt+T)
cd Desktop/ideviceactivate-master
make
sudo make install
ideviceactivate
share|improve this answer
    
Thanks. What exactly do I type after cd ideviceactivate? Path to extraction is /home/dc/Desktop/ideviceactivate-master. Have tried a couple of versions (with/without #) but it returns "no such file or directory" –  clifman Jan 25 '13 at 20:26
    
I've changed the instructions above. Post the output in the question if it doesn't work. –  Capt.Nemo Jan 26 '13 at 6:56
    
Thanks. Pasted in below my attempt which failed: –  clifman Jan 27 '13 at 20:23
    
Thanks. Pasted in below my attempt which failed: Oops. Can't paste in - too long. Not sure what you need to help. I don't think I got it downloaded correctly - what does 'fetch your dependencies' mean? –  clifman Jan 27 '13 at 20:32
    
Tried again-got this: make -C src make[1]: Entering directory `/home/dc/Desktop/ideviceactivate-master/src' gcc -o ideviceactivate ideviceactivate.c activate.c cache.c util.c -g -pthread -I/usr/local/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -pthread -L/usr/local/lib -limobiledevice -lplist -lusbmuxd -lgthread-2.0 -lrt -lgnutls -ltasn1 -lxml2 -lglib-2.0 -lcurl ideviceactivate.c:27:39: error: libimobiledevice/lockdown.h: No such file or directory ideviceactivate.c:28:47: error: libimobiledevice ...plus much more error stuff, too long to post here.Help! –  clifman Mar 3 '13 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.