Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just few days after reinstalling ubuntu (see How to unencrypt encrypted home directory?) I found my pc showing weird error messages in console (something about read/write access). I rebooted it, checked disk from under USBStick, it was ok, ran apt-get update, apt-get upgrade, rebooted and got it loading, but stopping with showing "The system is running in low graphics mode" bla bla.

When I switch to console (Ctrl+Shift+F1) I see that encrypted home is not mounted so I guess it just can't find graphic configs. I still can mount it with ecryptfs-mount-private and I hope if I manage to get home mounted automatically graphics will start. There are posts saying that there is an option defined at /etc/pam.d/, but how exactly it should be enabled? Can't find it.

Thank you!

share|improve this question

1 Answer 1

You need to add the encrypted disk / prtition / folder / file / whatewer to /etc/crypttab so it gets opened automatically - provided you used an encryption that can be opened by cryptdisks. After that you need to add de opened device-mapper to the /etc/fstab so it gets mounted automatically.

Basically this should do the trick.

share|improve this answer
    
I'm not sure, but crypttab seems to be about different type of encryption - when whole partition gets encrypted. In my case only one home folder was encrypted. But anyway, after another update restart I got mouse working by modprobe psmouse and reconfigured X. Now it works. Thank you! –  user656449 Jan 24 '13 at 7:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.