Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I start an application using Crossover (or Wine), the application will always be the Wine Logo instead of the application logo. This is the same independent of the application being run or using Wine instead of Crossover.

That makes sense if the application has no logo, but it gets confusing running multiple Microsoft Office programs - and all of them have the same logo.

The hint text for the icon is also "Wine Windows Program Loader" instead of "Document 1 - Microsoft Word" as it should be.

Is there a way to configure Wine/Crossover to use application icons and title text? I am using the Faenza Icon Set.

EDIT: I have confirmed that this issue does NOT occur in Gnome Classic.

share|improve this question
1  
This used to work in previous versions of wine and ubuntu. Can you test this at 'classic' desktop environments like openbox or WindowMaker? Thus we could rule out a unity bug. –  aquaherd Jan 23 '13 at 18:58
    
I had unity as a tag as I suspected that (someone removed that tag). I re-added the tag and edited my post. –  Kupiakos Jan 23 '13 at 22:36
    
I think screenshots might help here. –  FEichinger Jan 31 '13 at 1:13
    
Possible duplicate? askubuntu.com/questions/39394/… –  fossfreedom Jan 31 '13 at 12:02
    
I've tried all of the workarounds posted in there. None have worked. It worked in 12.04, and for a while in 12.10, which makes me think I messed something up. –  Kupiakos Jan 31 '13 at 20:46
add comment

1 Answer 1

In this question you find a workaround Change Icon of Wine Application in Unity Launcher

Take a look at the answer from MHC

You need to add the following line into your .desktop-file

StartupWMClass=application.exe

(application.exe is the name of your EXE-file, it's case sensitive)

share|improve this answer
    
Already tried that. Plus, why should I have to modify every single one of my .desktop files? That'd take quite a while for the number I have. –  Kupiakos Feb 2 '13 at 22:03
    
It works on my machine (Ubuntu 12.04). I tried to give you a solution, sorry. –  TIIUNDER Feb 3 '13 at 15:33
    
I think the bug is actually a regression in Ubuntu 12.10, now that I think about it. It did work in Ubuntu 12.04 for me as well. I'm now in Ubuntu 13.04 an I just noticed the problem still occurs. I'll see if a bug already exists. –  Kupiakos Jun 19 '13 at 14:53
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.