Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use Canon i-SENSYS LBP7200Cdn network printer with Ubuntu 12.10. I have read official documentation, this and this. I have not achieved any solution yet. I tried CAPT software versions 2.20 and 2.40. All the manuals are different and always involve CUPS and CCPD services, but nothing helped me.

share|improve this question
1  
Could you please say what you have done? Which steps? –  BuZZ-dEE Feb 3 '13 at 1:38
    
@BuZZ-dEE I have followed the steps described in both posts. None of them worked for me. –  logoff Feb 5 '13 at 10:48

1 Answer 1

Unzip the contents of the driver download, select the 32-bit or 64-bit folder, debian, and extract the .deb files to a directory. To install, open in console and run:

sudo dpkg -i ./*.deb
share|improve this answer
    
I did it, obviously, it doesn't work. Moreover, the deb's have unsatisfied dependencies that Ubuntu 12.10 doesn't have. –  logoff Feb 3 '13 at 12:48
    
That's strange, it says dependency error on libraries that are installed. Running sudo dpkg -i --force-depends ./*.deb installs it anyway, see if that works. –  NoBugs Feb 3 '13 at 16:23
    
The maintainer listed in the .deb is sup-debian@list.canon.co.jp, you should probably report the bug to them. –  NoBugs Feb 3 '13 at 16:25
    
If I use force option, it doesn't work, obviously, because the binaries failed to load library dependencies. Some packages had changed the names. –  logoff Feb 4 '13 at 9:38
    
Try to install those manually, and if they're only renamed libraries (incorrect dependencies in .deb file), --force-depends should make it install anyway. –  NoBugs Feb 4 '13 at 16:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.