Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to run a C code on an Android tablet from my computer which has Ubuntu 12.04. But when I run the application on android the tablet is not getting detected.

Please help me as to what to do.

share|improve this question
    
I'm not sure what you are trying to accomplish. An android tablet doesn't natively run "a C code". Can you explain what you try to do, and how you suppose this should work? You can look into the Android NDK to incorporate code into an APK, but I don't think this is wat you are looking for. –  Nanne Jan 23 '13 at 8:58
    
@Nanne ok basically m trying to connect a tablet pc to my computer which has Ubuntu 12.04, when i run the ndk code on android application it showing me the following error ???????????? no permissions on the android device part –  Neha Sharad Umachigi Jan 24 '13 at 5:51
    
This is important information: please add it to your question (so add what you try to do, EXACTLY how you try to do it, and the exact error you get.) –  Nanne Jan 24 '13 at 8:13
    
@Nanne thnx but i resolved it. –  Neha Sharad Umachigi Jan 24 '13 at 9:13
    
It would be really helpful if you did add some information to the question, and answered it yourself. It helps future googlers/AU-ers, and will give you some more reputation here as well. –  Nanne Jan 24 '13 at 9:19
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

You could do this with adb.

adb is run from the terminal, and allows you to run shell commands on the phone. You could write C code which executes adb via system().

It might be easier to just write a shell script.

share|improve this answer
    
My system which has Ubuntu 12.04 on it, even though it was detecting a Tablet PC via usb cable but it was unable to run my application on it since usb driver was not set properly. When i changed the .rules from /etc/udev/rules.d its working well now. I did the following update in the 70-persistent-cd.rules SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666", GROUP="plugdev". –  Neha Sharad Umachigi Jan 24 '13 at 10:43
    
After doing this close the file and restart the service as follow sudo service udev restart –  Neha Sharad Umachigi Jan 24 '13 at 10:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.