Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After fiddling around a lot with Rhythmbox and Banshee one day, I had to xkill them and logout a few times, and I think I remember seeing some error message asking for the keyring. I entered my password and it went away. After that, I had not realised that whenever I hibernate, the computer pretends that it has gone into hibernation and it seems perfectly okay, until the next time I start. The computer then does not resume from hibernate, it instead starts as though it had been shut down and I lose all unsaved data.

Steps taken:

I suspected an error in swap and tried reformatting the swap partition in GParted and turned it back on, to no avail. On the subsequent boots, the swap drive is no longer being recognised, and hence now I don't even see the hibernate option. Of the possible reasons given by Gparted, I think this ("The device entry /dev/sda7 is missing") is the relevant one. How do I set it right and re-enable hibernation? (Even the command sudo pm-hibernate doesn't work now since the swap partition isn't recognised.)

share|improve this question
    
I had exactly the same problem as this: askubuntu.com/questions/154958/… before I messed it up even further by taking the steps mentioned. –  Abhinav Jan 23 '13 at 4:14
add comment

1 Answer 1

up vote 0 down vote accepted

I found the answer! My boot menu was long and had multiple entries. Hence I decided to reformat the swap partition, and restarted. I then ensured that the UUID of the newly created partition as mentioned by GParted was the same as that of the computer's registry.

I hence edited the file /etc/fstab using gksu gedit /etc/fstab and updated the UUID there.

This made sure that my swap was back in business in a clean condition. I then updated the GRUB entry. This was where the problem was- I added the option "resume=/dev/sda7" to the file /etc/default/grub in the appropriate place a countless number of times, but my system still booted back as though it had not hibernated but shut down.

Then, while booting, I decided to edit the menus and look at the boot entries, and it turned out that the one that I was using to boot it up had the wrong UUID of the swap partition! I then edited the parameters there, booted in, and edited the menus properly once again, before updating grub.

Now everything is working as smoothly as I'd wish. :)

[What I think happened was, the default grub menu was the one being edited, and the default entry is the Windows one.]

share|improve this answer
1  
You don't have to edit /etc/default/grub. You can update the line RESUME=UUID=xxxxxx to match the new swap UUID in /etc/initramfs-tools/conf.d/resume and then regenerate the initrd.img with sudo update-initramfs -u –  bcbc May 8 '13 at 0:07
    
Thanks! I'll keep that in mind if it happens next time. –  Abhinav May 18 '13 at 21:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.