Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unity dash is really slow and unresponsive, it takes between 5 and 20 seconds just to load.

I'm running a laptop with 2gb ram, AMD Turion(tm) 64 X2 Mobile Technology TL-64 × 2, Gallium 0.4 on ATI RS690 graphics. The original install is ubuntu studio, which i have added ubuntu desktop to.

As a test I did a clean install of ubuntu studio, then ran updates and added ubuntu desktop + unity, this had no effect.

The output of /usr/lib/nux/unity_support_test -p is:

OpenGL vendor string:   X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS690
OpenGL version string:  2.1 Mesa 9.0

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

sudo lshw -C video gives the output:

*-display               
   description: VGA compatible controller
   product: RS690M [Radeon X1200 Series]
   vendor: Advanced Micro Devices [AMD] nee ATI
   physical id: 5
   bus info: pci@0000:01:05.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi vga_controller bus_master cap_list rom
   configuration: driver=radeon latency=64
   resources: irq:43 memory:f0000000-f7ffffff memory:f8100000-f810ffff ioport:9000(size=256) memory:f8000000-f80fffff

Edit: I used system monitor to check CPU and memory usage, despite unity very slow and unresponsive CPU usage never went above 50% neither did memory use.

I'm pretty sure it's something linked with unity dash as once programs are open they run relatively fast. There is no more lag than I would expect browsing the web or typing this. The problem is when i press super key or ALT and try to type, I could have a nap before it displays what I've typed. Also the side bar is unusable, it takes forever to appear if at all and disappears to quickly for me to click on anything.

sudo hdparm -v /dev/sda gives:

/dev/sda:
multcount     =  0 (off)
IO_support    =  1 (32-bit)
readonly      =  0 (off)
readahead     = 256 (on)
geometry      = 24321/255/63, sectors = 390721968, start = 0

sudo hdparm -Tt /dev/sda gives:

Timing cached reads:   1344 MB in  2.00 seconds = 672.19 MB/sec
Timing buffered disk reads: 136 MB in  3.01 seconds =  45.15 MB/sec
share|improve this question
    
Have you installed the drivers for your graphics card? –  DaimyoKirby Jan 23 '13 at 2:42
    
I have the same problem. The entire OS seems a bit laggy to me. –  masfenix Jan 23 '13 at 2:44
    
How do you install the drivers for the graphics card? –  Rob Jan 23 '13 at 2:45
    
I've experienced sluggish performance in Unity. For me it's usually unnecessary services and configuration errors. In other words, it may not have anything to do with your graphics configuration. –  victorias egret Jan 23 '13 at 3:31
    
I don't think it's unnecessary services, as i did a clean install of ubuntu studio then added ubuntu desktop. (the reason for ubuntu studio is I use the included software and like having the low-latency kernel for graphic and audio editing), I want to uses unity for just general stuff which is most of the time. What could be conflicting/incompatible/configuration error? –  Rob Jan 23 '13 at 11:19
add comment

2 Answers 2

Why are you wondering that a computer with an old graphics card and 2GB of slow RAM can't run a desktop with effects enabled?

I would say you need reflect here on what are you needs and what you would like to see happening depending on you definition of really slow and when that happens.

  • Test your hard disk for speeds and access time, a slow hard drive will make the results on the dash hard to load and that might slow down accessing it;
  • Create a file (or edit a present one) in you home folder with the name .xprofile with your favourite text editor, ie: nano ~/.xprofile and add

    export UNITY_LOW_GFX_MODE=1

    This will load Unity without the special effects that it normally uses making it more responsive

  • Test another desktop environment, XFCE and LXDE are much littler on effects and would speed up computer usage and tasking in your case.

For a more complete list and comparison of different desktop environments and shells please have a look at What different desktop environments and shells are available?

It will help decide and install a different desktop environment on your system, consider any of the following first: XFCE, LXDE or GNOME Classic.

share|improve this answer
    
I also think you should try a lighter DE, like Gnome Classic or XFCE. –  ThiagoPonte Jan 23 '13 at 12:17
    
I do use XFCE, that is default for ubuntu studio. The point is my hardware (CPU/memory) aren't being utilised - maxing out at 50%. that makes me think hardware is not the limiting factor (although i no very little about graphics cards). I swapped to ubuntu a few years ago because it was faster than windows (7), unity on Ubuntu 12.10 is 10x slower than windows ever was! –  Rob Jan 23 '13 at 13:29
    
Check your hard disk speed and access, retrieving results from it might be the issue. Also disable the online services that are enabled by default on the dash. Graphic card resources cannot be measured easily and the Unity uses those heavily, it can be that your card is just getting old for those, try the export UNITY_LOW_GFX_MODE=1 solution. –  Bruno Pereira Jan 23 '13 at 13:58
    
Some hard disk results posted above. export UNITY_LOW_GFX_MODE=1, which removed the special effects, but had only marginal effect on speed, leaving unity still almost unusable. –  Rob Jan 23 '13 at 14:41
    
I am new to ubuntu. How do I possibly replace an entire desktop with XFCE? –  masfenix Jan 23 '13 at 17:37
show 3 more comments

Unity in Ubuntu 12.10 is really slow. A better option is to switch the Ubuntu desktop environment to Lubuntu, more details can be found here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.