Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the script below to run FFmpeg on Ubuntu 10.10. I followed these instructions to install FFmpeg & x264.

While ffmpeg does capture the screen it does not capture the mic audio. I've checked that the mic works via "System Preferences". Anyone have any ideas on what the problem(s) could be and suggestions on how to resolve this issue? Thanks.

ffmpeg -f alsa -ac 2 -i hw:0,0 -f x11grab -r 30 -s $(xwininfo -root |  grep 'geometry' | awk '{print $2;}') -i :0.0 -acodec pcm_s16le -vcodec  libx264 -vpre lossless_ultrafast -threads 0 -y screen-capture.mkv
share|improve this question

closed as too localized by fossfreedom Feb 21 '12 at 21:29

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Have you checked Sound Preferences to ensure that your Mic is the current input source? –  Michael Curran Feb 3 '11 at 17:29
    
I had problems with alsa blocking sometimes. have you tried oss and dev/dsp? –  hbdgaf Feb 3 '11 at 17:34
    
Helloooo, are you there? –  belacq Mar 30 '11 at 16:37
    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyway or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reason(s) why you want it open. Regards –  fossfreedom Feb 21 '12 at 21:29