Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I posted this question on SuperUser and was told to look up the specs for [my] specific wireless card and see if there is a Linux driver for it.... Essentially I have an issue with my wireless configuration and it could be because of a bad or non-existent driver for my wireless card.

I'm new to Ubuntu (I have 12.04 installed) and can't seem to find the exact model of my wireless card, and similarly, which driver I need for it. I tried running lsmod but couldn't decipher if what I need is already loaded.

So I ask: how can I tell what device driver is needed to support the wireless card that my laptop shipped with? Thanks in advance!

Update:

Running lspci -nn | grep 0280 produces the following output:

02:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]

Searching these forums for the 14e4:4359 driver, I found this post which seems to be very similar to the problem that I am having. However, seeing that my question is concerned with 12.04, and the other question is with 12.10, and seeing that the other question is not the exactly the same scenario as what I'm describing, is more than 3 months old, and was never definitively answered, I argue that this is not a duplicate!

Like that other question, running sudo iwconfig produces the following output on my machine:

lo        no wireless extensions.
eth0      no wireless extensions.
tun0      no wireless extensions.

Running sudo modprobe wl produces:

FATAL: Module wl not found.

Running dmesg | grep wl produces:

[ 2.232664] ACPI Error: [EABF] Namespace lookup failure, AE_ALREADY_EXISTS (20110623/dswload2-316)

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Please open a terminal and run:

lspci -nn | grep 0280

Find the eight-digit PCI.ID for your wireless device and search this forum or ubuntuforums.org for the PCI.ID and you will find out what driver is required. If you get stuck, post it here and we'll help. Here is a sample from my machine:

Intel Corporation Centrino Advanced-N 6200 [8086:4239]

In my example above, a search for 8086:4239 suggests the driver is iwlwifi.

share|improve this answer
    
Thanks @chili555 (+1) - I updatedmy question to show a few other commands that I ran (yours is included) as well as a post from this site for a very similar incident. In that question, two members suggested installing firmware-b43-installer, bcmwl-kernel-source or bcmwl-sta-source to fix the issue. I don't want to go installing a ton of stuff on my machine unnecessarily. Is one of these the likely culprit? Thanks again! –  zharvey Jan 22 '13 at 21:14
    
Wow - just noticing now - @chili555, you were one of the answerers in that other question! –  zharvey Jan 22 '13 at 21:29
    
The correct driver for your device can be installed with: sudo apt-get install bcmwl-kernel-source. Then do: sudo modprobe wl and your device should be working. –  chili555 Jan 22 '13 at 22:28
    
@chilli555 - thank you! That was indeed it. Problem solved! –  zharvey Jan 22 '13 at 23:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.