Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My issue arose when I was attempting to uninstall an application from my windows server 2003 box. I was constantly getting errors when trying to uninstall the software so I booted the server into safe mode with networking to troubleshoot the issue. To do this I ran MSCONFIG and accidently restarted the server in safe mode WITHOUT networking.

This 2k3 box is enrolled in my active directory but is not a domain controller. Once I realized what I did I tried entering the domain administrator password hoping that the profile and credentials would have been cached, but of course they were not. I then tried using what I believed was the local administrator password which was also unsuccessful. At this point I assumed the simplest thing to do would be to wipe the password out using chntpw which I had on an old disk from way back. I ran through the process and the commands completed successfully, and yes I made sure to use this to unlock the account as well, however when I reboot the server I still can not login.

I think I am now at the point of stopping to try and reset the password, unless any of you can give me another idea of how to do this, and am wondering if there is anyway to get a command prompt open and run MSCONFIG so I can rest the .ini and boot the server back up normally? Any help would be greatly appreciated.

share|improve this question

closed as off topic by Jorge Castro, roadmr, psusi, Lekensteyn, gertvdijk Jan 22 '13 at 21:23

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
This Q&A is about Ubuntu Linux only (See the FAQ). Questions about Windows should be asked on Super User. Thanks! –  Seth Jan 22 '13 at 19:37

2 Answers 2

Well, since this is Ask Ubuntu, this can be solved by, well, using Ubuntu.

Grab an Ubuntu Live CD image (x86 desktop would be fine) from ubuntu.com, burn it (or write to USB if your machine supports USB boot and you have a spare USB stick lying around), and boot from it. Assuming you've been shutting down your server cleanly - and assuming you haven't encrypted and/or compressed your server's C: drive - Ubuntu should be able to mount the local hard drive's NTFS partition(s) and allow you to edit the respective .ini files (on top of whatever else you need to do to reset/recover the passwords). Note that you won't have access to MSCONFIG per se; instead, you'll have access to gedit (like Notepad, but way more powerful), and you'll need to know where the .ini file is located.

Or, while you're at it, you could just install Ubuntu and be done with all your Windows-related problems :)

share|improve this answer

Thanks for your reply, the information is greatly appreciated. I wouldn't even waste my time with attempting to reset the password normally as I have physical access to the server and no one has even noticed it is offline after almost a week, however there is an important database residing on the server that I am desperate to get back.

I am currently in the process of downloading and burning a copy of Backtrack and Ubuntu to hopefully resolve this issue. I noticed you stated in your post "assuming you haven't encrypted and/or compressed your server's C: drive." Now I haven’t encrypted the drive but whole resin I am in this disaster is because our company was issued new software and I was instructed to load it on my server 2k3 box. The space requirements for the new software is ludicrous and in an effort to make everything fit I compressed the drive. (this proved to be pointless as I was still short 1.4GB of disk space)

Is there any way for me to mount the drive using the Ubuntu live disk, remove the software, uncompress the drive and then continue on with your previous solution?

Thanks again for your help.

I apologize for my ignorance, I have had limited exposure to Linux operating systems and am not overly familiar with doing much of anything from a command line.

share|improve this answer
    
Welcome to Ask Ubuntu! The nature of the content here would be more suitable for a comment than an answer. –  nick Jan 22 '13 at 21:48
    
That was actually a goof-up in my explanation; NTFS-3G (Ubuntu's 'userspace' NTFS driver) apparently does support natively-compressed files on NTFS partitions nowadays, so there shouldn't be a problem as long as it's not encrypted. Just mount the drive (the graphical live CD should do this automatically when you double-click the drive's icon), make your .ini edits, and reboot back into Windows. Depending on the database format, you might be able to yank out the database files (in a MySQL database, this would be the .frm, .MYD, and .MYI files) and move them to another server, if needed. –  YellowApple Jan 22 '13 at 21:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.