Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a brand new Lenovo Thinkpad T530 from my work recently, with xubuntu installed on it. It's extremely snappy, apart from booting. The moment it's slow (~2 minutes) is between entering my password in the login screen up until the point where my desktop comes up. I've been able to trace the problem to the existence of a usb0 network interface, which is trying to come up.

If I run sudo ifconfig usb0 down before entering my password (through another screen), it shows my desktop almost immediately. Google doesn't make me any wiser as to how I should disable this usb0 interface, but I'm pretty sure I won't use it and I'd like my laptop boot a bit faster.

share|improve this question
1  
Do you have anything plugged on the USB ports, besides keyboard and mouse? An android cellphone perhaps? –  ThiagoPonte Jan 22 '13 at 18:18
    
@ThiagoPonte Nope, not even a keyboard or mouse at the moment, the problem still persists. –  Berry Langerak Jan 22 '13 at 19:20
1  
See if there's any reference to usb0 in the file /etc/network/interfaces. –  ThiagoPonte Jan 22 '13 at 19:36
    
@ThiagoPonte Alas, there's no reference to usb0 in /etc/network/interfaces. So I'm guessing NetworkManager is the culprit here. Any clue ad to how I can disable usb0 (through /etc/network/interfaces, startup files, or otherwise)? –  Berry Langerak Jan 22 '13 at 22:43
    
Some internal WWAN cards are recognised as USB devices. Do you have such a card installed? It is probably a driver or configuration error. Can you post the output of lsusb and lspci? –  LiveWireBT Jan 28 '13 at 13:50

1 Answer 1

You could try putting this into /etc/network/interfaces:

# Set up an interface which will not be allocated an IP address by
# ifupdown but will be configured through external programs. This
# can be useful to setup interfaces configured through other programs,
# like, for example, PPPOE scripts.
#
auto usb0
iface usb0 inet manual
      up ifconfig $IFACE 0.0.0.0 up
      up /usr/local/bin/myconfigscript
      down ifconfig $IFACE down

Note that this suggestion was taken from this thread in ubuntuforums, i haven't tested it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.