Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Few days ago I encountered a problem with dual-monitor configuration in Ubuntu - unwanted launcher bar on second monitor. The problem was reported here several times before. The solution for that is to change launcher placement option in Settings > Displays.

However, while trying to do that I discovered that I have no such option! I have enclosed screenshot as a proof.

enter image description here

Do you have any hints what should I do in order to "reveal" this option? Moreover - any guess what might have caused it to disappear?

I also put some additional information which may be helpful.

After installation of Ubuntu I have tried switching to gnome-shell. This went totally wrong and I ended up with semi-installed shell (no titlebars etc.). In order to run unity I'm forced to execute unity command twice. I have no idea how this could affect system settings - I'm informing you just-in-case.

Output of lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Output of xrandr:

Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1600x900       60.1 +   40.0  
   1440x900       59.9  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1680x1050+1680+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1680x945       60.0  
   1400x1050      74.9     60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       74.9     59.8  
   1152x864       75.0  
   1280x768       74.9     59.9  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   800x600        72.2     75.0     60.3     56.2  
   848x480        60.0  
   640x480        72.8     75.0     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      59.9*+
   1680x945       60.0  
   1400x1050      74.9     59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       74.9     59.9  
   1152x864       75.0  
   1280x768       74.9     60.0  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   800x600        72.2     75.0     60.3     56.2  
   848x480        60.0  
   640x480        72.8     75.0     60.0  
   720x400        70.1  
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)

That's it. Hopefully above outputs are sufficient. If not - let me know.

Warm regards.

Edit: This happens on newest version of Ubuntu (12.10).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I don't know why it may have disappeared, or what version of Ubuntu you may be using. However, one workaround might be to use CompizConfig Settings Manager (assuming Unity 3d).

sudo apt-get install compizconfig-settings-manager

The option is under the Unity Plugin, Experimental Tab->Launcher Monitors (All desktops vs. Primary Monitor). Here's a screenshot:

enter image description here

share|improve this answer
    
This is correct and what I personally do as well, but it should be noted that "CCSM may totally ruin your unity install" Though I am not sure why, and that has never happened to me, it's the standard disclaimer. –  coteyr Jan 22 '13 at 17:54
    
It didn't changed anything even when I ran unity. I'm going to try logging out. –  slavko Jan 23 '13 at 11:41
    
I confirm - the workaround it working for me. Thanks! –  slavko Jan 23 '13 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.