Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my laptop to dual boot Windows 8 and Ubuntu 12.10, which is fine and all, but I have been updating the drivers on the Ubuntu side of things, but I have downloaded and executed NVIDIA-Linux-x86_64-310.32.run from nVidia, which didn't work.

I started to get this error message:

enter image description here

and could only view the desktop in 640x480 which wasn't enough to do anything. But then I tried following the instructions here, but it still hasn't worked. Can anyone give me a pointer in the right direction?

share|improve this question

2 Answers 2

When I tried to install an Nvidia proprietary driver roughly from scratch, I always had the same problem as you with the breaking of Desktop appearance and resolution. I never resolved by means of "software sources" nor "additional drivers" because the driver installed in this way is never detected, so you will not see any driver report line in both the cited programs. The problem of this, is because the Nvidia Optimus technology is implemented for the latest video cards released by Nvidia. Briefly, you have two video cards installed on your laptop (type lspci | grep VGA to find out); one probably is an embedded Intel and the other one is the Nvidia card; because saving power reasons, the Nvidia card on Windows systems is just waken up when the OS detects a large amount of graphic duty. For Linux, the Nvidia drivers don't take into account the presence of the embedded card, so it will not work. The only way it worked for me is by installing Bumblebee as suggested on many sites and forums (for example this Bumblebee installation). After installed, don't forget to check in your /etc/bumblebee/xorg.conf.nvidia file the line

Option "ConnectedMonitor" "DFP"

you have to change it to

Option "ConnectedMonitor" "CRT"

and you'll see the optirun glxspheres command working.

share|improve this answer

I would first try to use the proprietary drivers that come with Ubuntu. Installation is a lot easier and has for me always worked so far.

If you're still able to get to the desktop, search for "software sources" in the Dash. In there, go to the tab called "additional drivers" and select the nVidia drivers and click install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.