Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP g4-1387, core I5, 4Gb RAM, 8Gb swap and hybrid Intel/ATI graphics with Ubuntu 12.04.1 LTS.

Finally after installing AMD Catalyst 12.4 as described here I was able to Suspend. Hibernate and shutdown. With any other version superior to 12.4 my system hangs on shutdown, hibernating and suspending. Now it works but I am not able to hibernate correctly. When I do it I see disk activity "saving" my data, but when I turn on my computer again I get login screen and everything is gone, the system seems to shutdown instead of hybernating. I use this to hibernate:

sudo pm-hibernate

My kernel version is 3.2.0-36-generic according to uname -r and I have plenty free swap when I try to hibernate (almost all my 8Gb).

Thank you very much for your help.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Ok, I solved it. The problem seemed to be that I had /home and swap partitions encrypted. I tried to desencrypt the partitions but the problem persisted. So I did this:

  1. Backup my data (home folder in my case)
  2. Fresh install formatting /home and / partition
  3. Install ATI Catalyst 12.4 (not higher because it cause problems)
  4. Everything is working!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.