Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have

HP Presario (C2D, 500GB,3-GB, 32-bit system)
running Ubuntu 12.10 using KDE deskto along with windows 7

. I don't know what exactly the problem is. I have installed many softwares but unable to install Skype and Teamviewer. There might be other softwares too but I have tested only these two. I downloaded 32-bit deb package

skype-ubuntu-precise_4.1.0.20-1_i386.deb

When executing the above package, it gives the following error:

Error: Wrong architecture 'i386'

I have tried installing from Konsol and I was amazed:

dpkg: error processing skype-ubuntu-precise_4.1.0.20-1_i386.deb (--install): package architecture (i386) does not match system (amd64) Errors were encountered while processing: skype-ubuntu-precise_4.1.0.20-1_i386.deb

How come I could install amd64 on my 32-bit system?

Any help??

share|improve this question
    
It looks like you have a 64-bit system. What makes you think you have a 32-bit system? What is the output of grep flags /proc/cpuinfo? –  Gilles Jan 22 '13 at 14:17
    
What is the output of dpkg --print-architecture? This is the architecture you have installed, which can vary from the architecture of your hardware. The architecture you have installed determines which .deb files you need to download if you want to install them directly. –  Robie Basak Jan 22 '13 at 15:02
    
grep flags /proc/cpuinfoAnd the result is: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm and when I ran: dpkg --print-architecture it says i386 –  Zahid Gill Jan 24 '13 at 13:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.