Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used gparted to shrink the swap space and add it to the drive that had Ubuntu installed in it from Live boot. After doing so, I restarted the computer and then found a black screen saying just this: No bootable device -- insert boot disk and press any key.

Help. Thanks in advance.

Edit: I installed grub again, mounting the drive in which Linux is installed. Still, it gives the same message.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Problem solved. :) Boot-Repair fixed it, with no hassles. Here's how to get it:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair

I ran it and clicked Recommended repair and it fixed the problem automatically.

Basically it fixed problems with my GRUB.

share|improve this answer
    
You may accept your own answer. –  ThiagoPonte Jan 23 '13 at 12:08
    
Thanks. I will. Didnt think of that... Gotta wait 17 hrs though. :) –  Rifaz Nahiyan Jan 23 '13 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.