Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am sometimes getting error messages like the ones below.

System program problem

internal error

As I understand they are from some kind of debugging mode in the beta which I sometimes install. I have no problem with them in the beta. If I install it I do because I want to report bugs. But if I switch to productivity I don't want them. Until 12.10 they stopped when the final was released and I upgraded, but not this time.

I'm not experiencing anything not working so the messages just annoy me by now. Can anyone tell me how to disable them?

share|improve this question
2  
Duplicate: askubuntu.com/questions/135540/… –  Robie Basak Jan 22 '13 at 9:34
    
Yep, seems that way. I wouldn't call my question a duplicate but I found the answer in the other one ;-) –  André Stannek Jan 22 '13 at 9:37
    
So what happens to this question? You can click the delete button if you think it is redundant. If you think it is worth retaining because it is genuinely different, go ahead and answer it yourself and then accept your own answer. –  user25656 Jan 22 '13 at 10:50
1  
@vasa1 Just came back because I thought the same ;-) Wasn't really awake when I commented. I think it's worth retaining because the motivation for that answer is very different. Someone who has my problem will most likely not find the other question (same way as I didn't). –  André Stannek Jan 22 '13 at 11:06
    
@stonedsquirrel That's a good reason for this to exist, but we can (and I think should) still close this. As a duplicate, it will serve even better as a signpost to the master question. –  Eliah Kagan Jan 22 '13 at 11:25

3 Answers 3

The thing which creates these error messages, as far as I know, is called Apport. You may try uninstalling that.

share|improve this answer
    
You're basically right I think but there is an easier than uninstalling the whole thing. See my answer. –  André Stannek Jan 22 '13 at 11:11
    
There's no need to uninstall Apport. It can easily be disabled or enabled‌​. –  user25656 Jan 22 '13 at 11:30

As pointed out by Robie Basak I was able to find my answer in context of another question. Here is the essential part from that answer:

  • Go to Settings...Privacy...

    enter image description here

  • And in the Diagnostics Tab, uncheck the Send Error Reports to Canonical option:

    enter image description here

share|improve this answer
    
That didn't do the trick. I thought so first but the messages start appearing again :-( –  André Stannek Jan 24 '13 at 18:02
up vote 3 down vote accepted

Inspired by the answer by @ovc I looked up how to disable apport and found this question.

I had to edit /etc/default/apport and change

enabled=1

to

enabled=0

This way it is not started at boot. For not having to reboot simply stop the service with

sudo service apport stop

Let's see if the messages disappear now :-)

share|improve this answer
    
I just realised that @vasa1 also linked to that question. Sorry! –  André Stannek Jan 24 '13 at 18:11
    
Four days without a message. I think it's save to assume that this is the solution ;-) –  André Stannek Jan 28 '13 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.