Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I decided to give Ubuntu a try after all these years using only Windows as OS.

I downloaded that windows installer from their site and installed Ubuntu. Everything went well until I decided to update the drivers and apps. It seems to be a bad idea, because I can't see the sidebar anymore (the one with the "quick launch options") and some graphic elements from the OS are not present, like the top bar with the clock.

Another issue: I always see an error regarding Compiz after a couple of minutes, saying that it stopped responding.

Am I missing something?

I'm using the 12.10 64bit version.


I googled about the problem and it seems that Compiz is bugged like hell in 12.10. I'm uninstalling it and giving 12.04 a try. That's too bad, because I like many features from this version, specially the use and feel. But I can't stand using it without the left bar and a graphic interface at all.

share|improve this question

Have you tried to open system settings, select "appearance", then open the "behaviour" tab, and "Restore Default Behaviours"?
If it doesn't work try this:
Press Ctrl + Alt + t
Run unity --reset

If still doesn't work try this:

sudo apt-get install dconf-tools  
dconf reset -f /org/compiz/
share|improve this answer
Thanks for the answer. A couple of things happened: -The first step did not work. - When I tried to reset unit, a msg came up, telling me unit wasn't installed. Well, after I installed it, the "--reset" command became deprecated =S - The third step did not help me either. – darksoulsong Jan 24 '13 at 11:38

Had the same problem, and have you tried this:

sudo apt-get install --reinstall unity
dconf reset -f /org/compiz
unity --replace --reset-icon & disown

And it might work fine this way.

share|improve this answer

I had a similar error. The sidebar showed up in the guest session, but not in others. I had removed everything in the ~/.config folder to resolve the issue, following this guide: How To Fix: No Unity, No Launcher, No Dash In Ubuntu 14.04.

Sidebar showed after that automatically, but it hidden after restart system!

Second way: I created new user by adduser command, and copied my essential files to new user's folder

share|improve this answer
Removing “everything in the ~/.config folder” is probably a bit drastic … – Chriki Dec 12 '15 at 11:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.