Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I had ssh running on my LAN server. Suddenly (not sure what I did), I cannot access the LAN server via ssh. When I try, it just hangs for a while with no response and finally comes out with a timed out message.

ssh: connect to host port 22: Connection timed out

As I recall, maybe I got into some trouble trying to install phpmyadmin and pgmyadmin. Still cannot get that going either but this question is for SSH. I just can't reach my own LAN server from my own desktop.

Not sure if it matters, but I have TWO network cards and one's meant for Internet connection and the other just connects to the LAN.

Any ideas please, on how I can fix this?

EDIT: Here's the output of my route command

Destination     Gateway         Genmask         Flags Metric Ref   Use Iface

default         UG    100    0     0    eth0     *        U     0      0     0    eth1     *        U     0      0     0    eth0
share|improve this question
@maggotbrain There's the result of rout. I'm sorry it took long. I had to type this looking at my server screen. –  itsols Jan 22 '13 at 5:49
@maggotbrain yes, I can ping my server from the other LAN PCs. In fact I can ping it on both eth0 and eth1. It's a little hard for me to see how but I can. eth1 is on my network switch and eth0 goes to my 4-port ADSL router. Also eth1 is static. –  itsols Jan 22 '13 at 6:08
Have you verified that the sshd service is running on your server? What is the output of ps -ef | grep ssh? Have you tried restarting it with sudo ssh restart? –  Kevin Bowen Jan 22 '13 at 6:57
@maggotbrain I really appreciate you taking time on this. when I tried to restart ssh I got a message like this: ssh: Could not resolve hostname restart: name or service not known –  itsols Jan 22 '13 at 7:04
I'm not sure if this makes sense but I tried netstat -pant and it listed both eth0 and eth1 as listening on the same port. I thought it may be useful, but not sure. –  itsols Jan 22 '13 at 7:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.