Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I installed juju through the ppa and bootstrapped it, I haven't been able to deploy anything. Juju responds with this:

$ juju deploy mysql
2013-01-21 22:44:53,394 INFO Searching for charm cs:precise/mysql in charm store
2013-01-21 22:45:05,592 ERROR could not connect before timeout

It happens with every charm I've tried.

I'm running Ubuntu Server 12.10. Fresh install too. 12.10 has been a real pain. Probably going to revert to 12.04 and wait it out until Raring if it's not going to work soon.

share|improve this question

You would receive that error if you were unable to connect to the Juju charm store at So, you might be blocked by a firewall that is preventing you from connecting to the charm store and so it is timing out, when it tries to download the mysql charm.

You could check that you can connect to the charm store by trying the command:


It should save an index.html file if you can connect. If it times out you have a problem accessing the charm store and you would have to manually copy the charms locally and then use a command like:

juju deploy --repository /path/to/charm-repo local:mysql

If you want to download a copy of all the charms from the charm store for copying to your system then install the package charm-tools and use the following commands:

cd dir/where/you/will/store/this
mkdir -p charm-repo/precise
charm getall charm-repo/precise

If you have no luck and want to debug juju further use the -v flag for verbose output:

juju -v deploy mysql

Hope that helps.

share|improve this answer

I've got the exact same error and after running with '-v' it became clear the problem was with the zookeeper server, which indeed wasn't running:

2013-02-28 18:19:02,019:18960(0x7f172f531700):ZOO_INFO@zookeeper_init@727: Initiating client connection, host= sessionTimeout=10000 watcher=0x7f172eda0700 sessionId=0 sessionPasswd= context=0x1ec9150 flags=0

I couldn't find out why it wasn't running, but the problem went away after I changed my data-dir in environments.yaml and ran 'juju bootstrap' again.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Pilot6 Sep 30 '15 at 15:49
@Pilot6 this is an attempt to answer the question, with at least a partial answer. – Seth Sep 30 '15 at 18:40
@Seth I read it three times and after some consideration decided that it was rather a comment. – Pilot6 Sep 30 '15 at 18:47

I got same error, in MAAS 1.5

The problem was I set my MAAS server time as my local time PST, After I changed it to UTC , it worked.

After full installation of my services I changed time zone to my local time again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.