Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just resurrected an older PC to use as my linux box.
Before Installing Ubuntu I verified that the PC could connect to the internet. I installed Ubuntu and am now not able to connect to the internet

In a shell I type ifconfig and receive:

eth0 Link encap:Ethernet HWaddr 00:50:8d:74:90:a8  
    inet 6 addr: fe80::8dff:fe74:90a8/64 Scope:Link  
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1  
    CX packets:687 erros:0 dropped:0 overruns:0 frame:0
    TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:81475 (81.4 KB) TX bytes:6050 (6.0 KB)
    Interrupt:18 Base address:0xb000

lspci -nnk | grep -iEA3 "(network|ethernet)" returns:

02:0b.0 Ethernet controller [0200]: Sundance Technology Inc / IC Plus Corp IC P1
us IP100A Integrated 10/100 Ethernet MAC + PHY [13f0:0200] (rev 31)
Subsystem: ABIT Computer Corp. Device [147b:1c08]
Kernel driver in use: sundance
Kernel modules: sundance

uname -r returns:

3.2.0-29-generic-pae

I am connected directly (hardwired, no wireless) to the router in my home office

dmeg | grep eth0 returns:

[11.292409] eth0: IC Plus Corporation IP100A FAST Ethernet Adapter at 0001b000, 00:50:8d:74:90:a8, IRQ 18
[11.293132] eth0: MII PHY found at address 0, status 0x786d advertising 01e1.
[173.941125] ADDRCONF (NETDEV_UP): eth0: link is not ready
[192.986492] eth0: Link up
[192.986895] eth0: Link changed: 100bps, full duplex
share|improve this question
    
Welcome to Ask Ubuntu! We'll need more hardware information. Could you include the output of the following command run from a terminal? lspci -nnk | grep -iEA3 "(network|ethernet)" as well as uname -r –  gertvdijk Jan 21 '13 at 21:44
    
thanks gertvdijk - additional info 02:0b.0 Ehternet controller [0200]: Sundance Technology Inc / IC Plus Corp P1 us IP100A Integrated 10/100 Ethernet MAC + PHY [13f0:0200] (rev 31) Subsystem ABIT Computer Corp. Device [147b:1c08] Kernel driver in use: sundance Kernel modules: sundance uname -r gives back 3.2.0-29-generic-pae –  kohho Jan 21 '13 at 21:49
    
Please edit your question to provide new information. This is Q&A site, not a discussion forum, you see? :) –  gertvdijk Jan 21 '13 at 21:53
    
Please edit your question and tell what kind of connection you want to achieve: via modem, router, corporate LAN? –  aquaherd Jan 21 '13 at 21:58
    
Have you setup the connection in network manager? Seems like you didn't tell it to connect to the wired network. Just saying. –  user125026 Jan 21 '13 at 22:09

2 Answers 2

I"ve solved the problem by installing an NIC rather than using the ethernet connection on the mother board. Someone posted a comment on my question (that I can no longer see for some reason) that my problem sounded like a known bug with my network hardware. This prompted me to use a network card and it worked. Thanks All!

share|improve this answer

Try assigning an address to the interface, maybe through 'ifconfig', 'ip address', or 'dhcpcd'. Also, check to make sure that you can get a wired connection between other machines and the router--maybe the problem is in the router's side.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.