Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed the description on the website but when I try to drag the proxtube.crx file into the Tools tab my Unity launcher to the left gets highlighted and I can't seem to drop the file into Chrome in order to install it.

How can I fix this? I'm using Ubuntu 12.04 LTS x64 and Chrome Version 24.0.1312.52

share|improve this question

4 Answers 4

up vote 1 down vote accepted

In Chromium (tested) and according to deveoper notes in Chrome (untested) we can load extensions from chrome://chrome/extensions/. After unzipping the .crx files (which are basically ZIP compressed) we can browse to the file's directory by ticking the "Developer mode" box in the upper right corner to select "Load unpacked extensions...":

enter image description here

See also:

An alternative to Proxtube is the extension Stealthy which also works through proxies and can be used for any sites including YouTube.

share|improve this answer
1  
I have installed extensions for Chrome which are not in the official Webstore by downloading them to my desktop, enabling "developer mode" on the extensions page and then dragging the extension file from my desktop on to a blank space on the extensions page (not onto the tab). IMO, "Load unpacked extensions" is not applicable for .crx files (which are packed). I used to use "Load unpacked extensions" to point to an uncompressed folder containing uncompressed extension components. –  user25656 Jan 22 '13 at 2:57
    
@vasa1: thank you again for this note. –  Takkat Jan 22 '13 at 7:15
1  
@vasa1: Thank you. I managed to install it ticking Developer Mode but it seemed quite buggy. Like before I couldn't drop it on the extension page. After restarting Chrome and having only the Extension tab open it suddenly worked. Cheers! –  cruxfilm Jan 22 '13 at 8:10

Drag'n'Drop to install is in fact the right (and hassle free) way to install extensions in both Chrome and Chromium, but it's disabled by default. You can do it that way:

Open a terminal (Ctrl + Alt + T) and start your browser with this flag:

--enable-extensions

For example:

chromium-browser --enable-extensions for Chromium

or

google-chrome --enable-extensions for Chrome.

When your browser starts, navigate to Tools-> Extensions.

Drag the extension file (*.crx) to the extension tab. A small text window will indicate drop to install or something similar. Drop the file by releasing the mouse button and click yes when asked if you wish to install the extension.

share|improve this answer

I confirm as of this reply: Trying to install the Proxtube extension for Google Chrome I cannot drag the .crx file into Chrome. What's wrong?

That it does not allow you to drag a .crx file onto extensions page if it's opened within the other tabs. It is enough though to open a new window (without a need to restart or close any other tabs) and open Tools->Extensions page as a single tab. Then it will allow to drag the file there.

Chromium: Version 25.0.1364.160 Ubuntu 12.04

share|improve this answer

Try doing a Ctrl+O from within Chrome and installing the .crx file that way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.