Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Installing Ubuntu 10.10 I get the GRUB2 boot manager. By default is does instant booting of the first entry, i.e. you have to hold the Shift key while booting when you want to enter the menu.

How can I disable this behavior? I mean, how can I configure GRUB2 such that it always displays its menu and uses perhaps a timeout of 5 seconds for the first entry?

share|improve this question

marked as duplicate by bain, Alaa Ali, Eliah Kagan, muru, Eric Carvalho Aug 9 at 22:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

up vote 10 down vote accepted

Check out the extremely detailed and well-written Wiki entry for Grub2. The setting GRUB_HIDDEN_TIMEOUT should be what you are looking for. But pay attention to the instructions on how to change settings.

share|improve this answer
6  
Yes, setting GRUB_HIDDEN_TIMEOUT= (yes, this a newline after the equal sign) and running update-grub disables instant booting. The grub menu is then displayed for GRUB_TIMEOUT seconds. IMHO this is a little bit unintuitive. The wiki entry is very detailed indeed - but the /etc/default/grub file should incorporate some of its details regarding the complex timeout logic as comments. –  maxschlepzig Feb 4 '11 at 0:01
    
@maxschlepzig +1 for the understatement a little bit unintuitive –  irrational John Apr 24 '12 at 4:55

[Using ZORIN]

I also found editing the GRUB_GFXMODE=640x480 settings fixed the problem. However, first, I had to add the grub-customizer.

Optional, if step 1 doesn't work

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer
  1. sudo apt-get install grub-customizer
  2. sudo apt-get update
  3. Find Grub Customizer in the GUI (for me it's in System>Administration>..., but for some it is fund under Applications>System Tools>..)
  4. Open Grub Customizer and select Preferences > Advanced
  5. Select GRUB_gfxmode (640X480) - if it is already selected, deselect it, reboot, and select it again.
  6. Cross your fingers and reboot!

I have no idea why this worked for me, but it worked on both of my computers, so hopefully it will work for you too!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.